Valeur vide pour ensemble

delphine - 19 juin 2017 à 14:26 - Dernière réponse :  delphine
- 19 juin 2017 à 14:57
Bonjour,

je souhaiterais écrire une formule qui me permet de signaler quand il manque des valeurs:
a 230 ??
a 156 ??
a ??
b 900 ok
b 458 ok
c 268 ??
c 302 ??
c 405 ??
c ??
d 120 ok
qui peut me dire que je n'ai pas toute les info pour a mais que je les ai pour b

quelqu'un saurait-il m'aider?
d'avance merci


Afficher la suite 

2 réponses

Répondre au sujet
mrjenkins 578 Messages postés jeudi 22 novembre 2007Date d'inscription 17 août 2017 Dernière intervention - 19 juin 2017 à 14:36
0
Utile
Salut

si je comprends bien.
Dans la colonne A, tu as l'identifiant de l'ensemble (a,b,c ou d).
Dans la colonne B, un chiffre ou vide.

Et tu veux qui s'il manque un (ou plusieurs) chiffres manquent pour un ensemble donné (a et c dans ton exemple), tu aies un message spécifique.

Si c'est ça, voila ce que je te propose en case C1 (à tirer vers le bas) :
=SI(NB.SI(A:A;A1) = NB.SI.ENS(A:A;A1;B:B;"<>");"OK";"KO")


Ca vérifie pour chaque ligne, le nombre de lignes contennant l'idenfiiant en A, et le nombre de case non-vides du même identifiant.


--
Commenter la réponse de mrjenkins
0
Utile
super c'est exactement ça
mille merci
bàt
Commenter la réponse de delphine