Signaler

Calculer liste déroulante [Résolu]

Posez votre question Elladan27 - Dernière réponse le 21 juin 2017 à 20:46 par Vaucluse
Bonjour,
je suis novice sur Excel, pouvez-vous m'aider.
j'ai 3 listes déroulantes et en fonction du choix de chaque liste la 4 ième cellule me donne la somme des 3 choix. chaque liste doit avoir une valeur numérique qui va de 1 à 5. je ne sais pas si je suis clair. chaque liste se multiplie ex. : choix liste 1 * liste 2 * liste 3
merci
Afficher la suite 
Utile
+0
plus moins
Bonjour
le plus simple:
faite u tabmeau avec vos listes selon cet exemple, à adapter:
liste 1 de A1 à A5
valeur des libellés de B1 à B5
liste 2 de C1 à C5
valeur des libellés de D1àD5
liste 3 de E1 à E5
valeur des libellés de F1 à F5


en H1: validation selon A1:A5
en I1 validation selon C1:C5
en J1 validation selon E1:E5

en K1:
=RECHERCHEV(H1;$A$1:$B$5;2;0)*RECHERCHEV(I1;$C$1:$D$5;2;0)*RECHERCHEV(J1;$E$1:$F$5;0))
bien entendu, ajustez les champs selon vos données

et si vous voulez éviter un affichage d'erreur quand une des trois cellules est vides:
=SI(OU(H1="";I1="";J1="");"";RECHERCHEV(H1;$A$1:$B$5;2;0)*RECHERCHEV(I1;$C$1:$D$5;2;0)*RECHERCHEV(J1;$E$1:$F$5;0)))

crdlmnt

Donnez votre avis
Utile
+0
plus moins
Bonjour,

Avec en A1 le choix1 / en B1 le choix2 / en C1 le choix3

Mettre en D1 =A1*B1*C1

Changer les références des cellules selon votre tableau

Cordialement
Donnez votre avis
Utile
+0
plus moins
Bonjour ,

je vais essayer d'être clair.
j'ai 3 listes déroulante sur la même ligne une en A1 une en B1 et la dernière en C1 dans chaque liste il y a du texte, il faut donner une valeur numérique pour chaque texte qui est de 1 à 5. en fonction du choix pris dans une liste il me faut une somme en D1. chaque choix d'une liste doit être multiplié par la suivante ce qui donne A1*B1*C1 et en D1 j'ai le résultat des multiplications.
Merci pour votre aide
PapyLuc51 1093Messages postés dimanche 3 mai 2009Date d'inscription 23 août 2017 Dernière intervention - 19 juin 2017 à 17:39
Bonjour,

OK mais il manque encore dans quelles conditions tu transformes du texte en valeur numérique.

Il nous faudrait un fichier exemple via cjoint

Cordialement
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour Elladan27.

Tu peux constater que tu n'avais pas été suffisamment clair !
C'est donc la première réponse, celle de Vaucluse, qui convient.
Donnez votre avis
Utile
+0
plus moins
Bonjour,

je ne comprends pas ce que Vaucluse veut dire en H1 Validation selon A1:A5
A1:A5 c'est la sélection du texte mais validation c'est inconnu.

Merci pour vos réponses
Vaucluse 20196Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 23 août 2017 Dernière intervention - 20 juin 2017 à 18:00
Bonjour
il s'agissait simplement de donner un exemple de solution
A1 à A5 etc... était supposé pour moi représenter les listes de bases qui alimentent vos menus déroulants
Mais je ne connais pas votre fichier
si vous pouvez le déposer (même en bidonnant quelques données si besoin) ici:
http://www.cjoint.com
et revenir ici coller le lien créé sur le site.
on y verra plus clair et on pourra mieux vous aider
si vous déposez le fichier, rajouter quelques explications.
crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Merci pour cette réponse rapide,

Le fichier http://www.cjoint.com/c/GFuqqV8Wu4j

Merci encore
Vaucluse 20196Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 23 août 2017 Dernière intervention - 20 juin 2017 à 18:32
Votre fichier en retour avec la formule en D1 et la correction des validations dans A1,B1,C1
problème dans votre fichier:
les textes que vous avez placés au clavier dans les fenêtres de validation ne correspondent pas exactement à vos tableaux en ligne 6 à 10 (des blancs encadrent le signe = dans les textes de validation, alors qu'il n'y en a pas dans le tableau 6:10)
Voyez dans le fichier en retour comment sont installées les validations par liste, en faisant référence aux listes de votre feuille plutôt qu'à des textes au clavier.
La correspondance des textes est donc assurée.
http://www.cjoint.com/c/GFuqBMhKxNC
revenez si besoin de + d'infos
crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Vaucluse,
je n'arrive pas a voir après $A$6 c'est un espace qui a entre $6 $B$10
J'essaye d'adapter votre formule.
Je n'arrive pas à comprendre votre dernier paragraphe "faisant référence aux listes de votre feuille plutôt qu'à des textes au clavier"

Merci
Vaucluse 20196Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 23 août 2017 Dernière intervention - 20 juin 2017 à 20:41
dans le fichier, sélectionnez par exemple votre cellule A1
afficher via le ruban la fenêtre de validation
onglet données / validation...
voyez ce qui est inscrit dans le cadre inférieur de la fenêtre, à la place des textes (non conformes) qui étaient écrits dans votre ancien modèle
Maintenant,la liste qui s'affiche quand vous pointez la flêche en A1 correspond aux textes inscrit en A6:A10, sans erreur possible

voyez ici:
http://www.cjoint.com/c/GFusWtnJlnC

notez que si vos listes de références sont sur une autre feuille, il faut, pour certains Excel, nommer le champ et utiliser le nom à la place de l'adresse

pour nommer par exemple A6:A10 simplement:
  • sélectionnez A6:A10
  • placez le curseur dans la case adresse à gauche de la barre de formule
  • effacer l'adresse affichée
  • tapez le nom voulu au clavier (sans blanc) par exemple: LISTE_1
  • touche entrée


et ensuite pour placer une validation dans une cellule, voyez dans la fenêtre de validation, là où il est écrit =$A$6:$A$10 remplacez par
=LISTE_1
n'oubliez pas le signe =

(avec bien entendu un nom différent pour chaque liste)

bon courage

crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

Mille mercis Vaucluse, c'est génial tout fonctionne à merveille. J'ai vu mon erreur !!!
Je marque le sujet comme résolu.

Merci encore
Vaucluse 20196Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 23 août 2017 Dernière intervention - 21 juin 2017 à 20:46
Pas de quoi
Bonne route
crdlmnt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !