Nombre de cellules situées apres un caractere preci. [Résolu]

Vicky2k - 17 juin 2017 à 10:25 - Dernière réponse :  Vicky2k
- 17 juin 2017 à 21:56
Bonjour chers tous,
j'ai besoin de votre aide pour trouver une formule Excel permettant de trouver le nombre de cellules situées après un caractère indiqué (sur la même ligne).
Exemple:
Cellule A1:"CO";A2:"2";A3:"e";A4:"oy";A5:"1";A6:"2";A7:" ";
Comment trouver le nombre de cellules vides situées après la cellule contenant "e" ?
Comment trouver le nombre de cellules non vides situées après la cellule contenant "e" ?

Afficher la suite 

5 réponses

Répondre au sujet
gbinforme 14411 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 17 juin 2017 à 12:01
0
Utile
Bonjour,

Ta question est mal posée car la cellule A1 ne contient pas de cellules vides ou non.
Commenter la réponse de gbinforme
yg_be 4116 Messages postés lundi 9 juin 2008Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 17 juin 2017 à 12:57
0
Utile
1
bonjour, ton exemple serait plus clair si tu donnait quel nombre tu voulais obtenir..
Bonjour ,
merci pour votre promptitude.
Je veux avoir dans ma cellule de calcul comme résultat 1 (pour le nombre de cellule vide :A7 etant vide)
Et avoir dans la 2e cellule de calcul 3 (pour le nombre de cellules non vides situées après la cellule contenant "e")

Merci .
Commenter la réponse de yg_be
gbinforme 14411 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 17 juin 2017 à 21:16
0
Utile
1
Bonjour,

dans ma cellule de calcul comme résultat 1
=NB.SI(A1:A7;"")

Cela devrait donner le résultat.

dans la 2e cellule de calcul 3
=NBVAL(A1:A7)-NBVAL(DECALER(A1;;;EQUIV("e";A1:A7;0);1))


Bon test
Super gbinforme
Merci à vous les amis.
Commenter la réponse de gbinforme