Signaler

Somme.si avec somme plage variable !! [Résolu]

Posez votre question ma - Dernière réponse le 14 juin 2017 à 15:30 par ma
Bonjour,
Je souhaite faire une somme si mais avec une plage somme variable !!
Exemple :

Pdt janvier fevrier
Pomme 5 9
Orange 8 4
Fraise 1 7
Pomme 6 3
orange 7 2
Pomme 9 7

Je souhaite choisir Pomme et janvier et Excel me calcule la somme si de pomme sur colonne janvier. et si je change la seceltion en fevrier la somme si change de colonne automatiquement pour aller chercher dans le colonne du mois de fevrier.

A noter que le tableau sera une extraction d'une base et je peux pas figer les noms des colone ni son emplacement, càd que la fois suivante le tableau ressmplera pas exemple à :
Fruit Mars juin decembre
Pomme 4 2 7
Orange 8 5 6
Fraise 9 4 1
Pomme 1 6 8
orange 6 7 4
Pomme 7 1 5

et donc la formule doit s'adapter.

Merci d'avance pour votre preciseuse aide.
Afficher la suite 
Utile
+0
plus moins
Bonjour

exemple à adapter
  • en A, titre de colonne en A1, produits en A2:A100
  • en B1,C1,D1,E1 les noms de mois
  • en F1 le nom du produit cherché
  • en F2 le nom du mois cherché

les écritures sont identiques aux liste et titre du tableau intial

=SOMME.SI($A$1:$A$100;F$1;DECALER($A$1;;EQUIV($F2;$B$1:$E$1;0);100))


le dernier 100 est la hauteur du champ et doit donc correspondre au nombre de lignes de l'adresse en début de formule

crdlmnt
ma- 14 juin 2017 à 15:29
Excellent et merci beacoup pour ton aide
Répondre
Donnez votre avis
Utile
+0
plus moins
@ Vaucluse

merci beacoup pour ton aide.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !