Signaler

Trouver le nombre d'heures ouvrées entre deux dates [Résolu]

Posez votre question Julnat - Dernière réponse le 7 juin 2017 à 16:25 par Vaucluse
Bonjour,

Ça fait des heures que je cherche sur le net pour trouver une formule qui fonctionne me permettant de trouver le nombre d'heures ouvrées entre deux dates pour le traitement d'un dossier.

Voici mes infos
En E2 --> 22/06/17 14:30 (format personnalisé jj/mm/aa hh:mm)
En F2 --> 03/07/17 9:30 (format personnalisé jj/mm/aa hh:mm)

Les heures ouvrées sont de 8 h 30 à 15 h 30 du lundi au vendredi (donc 7 heures par jour).

J'ai défini le nom "Feriés" pour la plage des jours fériés (u4:u16)
J'ai défini le nom "Hdeb" pour l'heure de début 8:30 (format heure hh:mm)
J'ai défini le nom "Hfin" pour l'heure de fin 15:30 (format heure hh:mm)

Normalement, je devrai obtenir 30 heures comme réponse puique le 30/06/17 est un jour férié dans ma liste, mais je n'y parviens pas.

Quelqu'un peu rapidement m'aider S.V.P.?

Afficher la suite 
Utile
+1
plus moins
Bonjour

effectivement Excel a un peu de mal avec les horaires en négatif

voyez celui ci et testez tous vos cas de figure

j'ai repris la, formule en utilisant vos champs nommés et en rajoutant un enK1 (Hjour) pour le temps journalier
Ca éclaircit la formule

https://mon-partage.fr/f/XFYGY3wN/

revenez si besoin

crdlmnt
Cette réponse vous a-t-elle aidé ?  
Donnez votre avis
Utile
+0
plus moins
Bonjour
pouvez vous détailler comment vous arrivez à 30 alors que du 22/6 au 3/7, en décomptant samedi, dimanche et le 30/6 considéré fériés, il reste 5 jours ouvrables complets que l'on doit, peut on croire, compter à 7H par jour? (soit les 23,26,27,28,29/6)
donc déja 35h plus ce qui correspond a E2 et F2 mais dont on ne sait pas quoi faire? c'est des dates de début, de fin, de quoi?
à vous lire
crdlmnt

Vaucluse 20142Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 16 août 2017 Dernière intervention - 7 juin 2017 à 15:40
Mais alors dans ce cas, que voulez vous comme résultat?

si c'est pour avoir une cellule vide en G, commencez la formule par:
=SI(OU(E2="";F2="");"";..................

et si c'est pour avoir une info différente; vous pouvez commencer avec:

=SI(E2="";"";SI(F2="";"un texte entre guillemets";......

et dans ce cas rajoutez une parenthèse à la fin de la formule


a + ?? :-))

crdlmnt
Répondre
Julnat- 7 juin 2017 à 15:43
Ok pour le SI(OU(.... c'est ce que je voulais.

Par contre pour la réponse si le dossier est traité dans la même journée, que dois-je ajouter dans la formule, car en G6, la réponse devrait donner 2:00 et non 9:00
Répondre
Vaucluse 20142Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 16 août 2017 Dernière intervention - 7 juin 2017 à 16:02
alors voyez ici, en espérant qu'il n'y ait pas de cas où la réponse est faite avant la question :-)))
http://www.cjoint.com/c/GFhobWsoHbj
crdlmnt
Répondre
Julnat- 7 juin 2017 à 16:15
Génial! problème résolu!!!
Une chance que vous exister :-)))

Devrait pas avoir d'autres situations...

C'était ma première expérience sur les forums, mais très enrichissante. J'ai beaucoup appris.

Encore merci,
Répondre
Vaucluse 20142Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 16 août 2017 Dernière intervention - 7 juin 2017 à 16:25
Pas de quoi
revenez si besoin
bonne route
crdlmnt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !