Trouver le nombre d'heures ouvrées entre deux dates [Résolu]

Julnat - 6 juin 2017 à 19:34 - Dernière réponse : Vaucluse 20877 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 18 décembre 2017 Dernière intervention
- 7 juin 2017 à 16:25
Bonjour,

Ça fait des heures que je cherche sur le net pour trouver une formule qui fonctionne me permettant de trouver le nombre d'heures ouvrées entre deux dates pour le traitement d'un dossier.

Voici mes infos
En E2 --> 22/06/17 14:30 (format personnalisé jj/mm/aa hh:mm)
En F2 --> 03/07/17 9:30 (format personnalisé jj/mm/aa hh:mm)

Les heures ouvrées sont de 8 h 30 à 15 h 30 du lundi au vendredi (donc 7 heures par jour).

J'ai défini le nom "Feriés" pour la plage des jours fériés (u4:u16)
J'ai défini le nom "Hdeb" pour l'heure de début 8:30 (format heure hh:mm)
J'ai défini le nom "Hfin" pour l'heure de fin 15:30 (format heure hh:mm)

Normalement, je devrai obtenir 30 heures comme réponse puique le 30/06/17 est un jour férié dans ma liste, mais je n'y parviens pas.

Quelqu'un peu rapidement m'aider S.V.P.?

Afficher la suite 

15 réponses

Répondre au sujet
Vaucluse 20877 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 18 décembre 2017 Dernière intervention - 7 juin 2017 à 08:07
+1
Utile
Bonjour

effectivement Excel a un peu de mal avec les horaires en négatif

voyez celui ci et testez tous vos cas de figure

j'ai repris la, formule en utilisant vos champs nommés et en rajoutant un enK1 (Hjour) pour le temps journalier
Ca éclaircit la formule

https://mon-partage.fr/f/XFYGY3wN/

revenez si besoin

crdlmnt
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de Vaucluse
Vaucluse 20877 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 18 décembre 2017 Dernière intervention - Modifié par Vaucluse le 6/06/2017 à 19:52
0
Utile
13
Bonjour
pouvez vous détailler comment vous arrivez à 30 alors que du 22/6 au 3/7, en décomptant samedi, dimanche et le 30/6 considéré fériés, il reste 5 jours ouvrables complets que l'on doit, peut on croire, compter à 7H par jour? (soit les 23,26,27,28,29/6)
donc déja 35h plus ce qui correspond a E2 et F2 mais dont on ne sait pas quoi faire? c'est des dates de début, de fin, de quoi?
à vous lire
crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Vaucluse 20877 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 18 décembre 2017 Dernière intervention > Julnat - 7 juin 2017 à 15:40
Mais alors dans ce cas, que voulez vous comme résultat?

si c'est pour avoir une cellule vide en G, commencez la formule par:
=SI(OU(E2="";F2="");"";..................

et si c'est pour avoir une info différente; vous pouvez commencer avec:

=SI(E2="";"";SI(F2="";"un texte entre guillemets";......

et dans ce cas rajoutez une parenthèse à la fin de la formule


a + ?? :-))

crdlmnt
Ok pour le SI(OU(.... c'est ce que je voulais.

Par contre pour la réponse si le dossier est traité dans la même journée, que dois-je ajouter dans la formule, car en G6, la réponse devrait donner 2:00 et non 9:00
Vaucluse 20877 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 18 décembre 2017 Dernière intervention - 7 juin 2017 à 16:02
alors voyez ici, en espérant qu'il n'y ait pas de cas où la réponse est faite avant la question :-)))
http://www.cjoint.com/c/GFhobWsoHbj
crdlmnt
Génial! problème résolu!!!
Une chance que vous exister :-)))

Devrait pas avoir d'autres situations...

C'était ma première expérience sur les forums, mais très enrichissante. J'ai beaucoup appris.

Encore merci,
Vaucluse 20877 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 18 décembre 2017 Dernière intervention > Julnat - 7 juin 2017 à 16:25
Pas de quoi
revenez si besoin
bonne route
crdlmnt
Commenter la réponse de Vaucluse