Signaler

[Excel] Vérifier existence cellules colonne A dans colonne C [Résolu]

Posez votre question chatBoO 16Messages postés vendredi 3 janvier 2014Date d'inscription 12 juillet 2017 Dernière intervention - Dernière réponse le 6 juin 2017 à 19:12 par chatBoO
Bonjour à tous,

Je me permets de venir vous demander de l'aide pour m'aider à régler un problème de fonction Excel sur un de mes fichiers.

Pour faire bref je voudrais savoir si les cellules de la colonne A sont présentes dans la colonne C. Si elle est présente la colonne B renvoi "Oui", sinon "Non".

J'ai donc utilisé les fonctions [SI()] et [EQUIV()] suivante dans la colonne B :

=SI(EQUIV(A2;$C$2:$C$3969;0);"Oui";"Non")

MAIS mon problème est que lorsque la valeur de la celule est présente dans la colonne C la fonction renvoi bien "Oui" mais par contre lorsqu'elle ne s'y trouve pas elle ne me renvoi pas "Non" mais N#A... Pourquoi ?

Car ma valeur si vrai est "Oui" et ma valeur si faux "Non"...

Peut-être la fonction EQUIV() n'est pas appropriée ou peut-être faut-il que j'imbrique des "OU" ou je ne sais pas... J'attends vos réponses et je vous remercie par avance de votre implication :-)

Pour vos tests je vous mets le lien de mon fichier Excel ci-dessous :

http://www.cjoint.com/c/GFgqjLLe16M

Merci encore =)
Utile
+1
plus moins
Bonjour
voyez simplement avec, en B2:
=SI(NB.SI(C:C;A2);"oui";"non")

vous pouvez aussi détecter directement en colonne A par msie en forme conditionnelle et cette formule dans la fenêtre de MFC:
=NB.SI(C:C;A1)

comme ici:
https://mon-partage.fr/f/FrBz6cBe/

crdlmnt

Cette réponse vous a-t-elle aidé ?  
chatBoO 16Messages postés vendredi 3 janvier 2014Date d'inscription 12 juillet 2017 Dernière intervention - 6 juin 2017 à 19:08
Merci la fonction NB.SI fonctionne très bien =^.^= =)
Répondre
Donnez votre avis
Utile
+1
plus moins
Bonjour.

" la fonction renvoi bien "Oui" mais par contre lorsqu'elle ne s'y trouve pas elle ne me renvoi pas "Non" mais N#A... Pourquoi ? " :
Ce n'est pas la fonction SI qui est en cause, mais bien la fonction EQUIV.
En effet tu demandes à cette fonction de rechercher une donnée qui n'existe pas ! Elle ne peut que te renvoyer la valeur d’erreur #N/A signifiant " aucune valeur n’est disponible " ...

Dans ton cas, la fonction NB.SI est plus appropriée :
=SI(NB.SI($C$2:$C$3969;A2)>0;"Oui";"Non")
Cette réponse vous a-t-elle aidé ?  
chatBoO 16Messages postés vendredi 3 janvier 2014Date d'inscription 12 juillet 2017 Dernière intervention - 6 juin 2017 à 19:12
Merci Raymond effectivement j'ai compris mon erreur avec la fonction EQUIV qui renvoi un numéro de ligne... mais avec ma fonction ce n'était pas possible ! alors qu'avec la NB.SI ça fonctionne au TOP ! Merci beaucoup =)
Répondre
Donnez votre avis
Utile
+1
plus moins
Merci à tous !! :) :) la fonction NB.SI fonctionne du tonnerre ! C'est vraiment un temps fou de gagner merci à vous la communauté CCM ! =)

J'espère pouvoir compter sur vous de nouveau si je suis perdu =^.^=.

Bonne fin de journée à tous !
Cette réponse vous a-t-elle aidé ?  
Donnez votre avis
Utile
+0
plus moins
chatBoO, Bonjour.

Essayez cette formule:

=SI(ESTNUM(EQUIV(A2;$C$2:$C$3969;0));"Oui";"Non")

Il est que ce que vous vouliez?
J'espère avoir aidé.
--
Belo Horizonte, Brasil.
Marcílio Lobão
chatBoO 16Messages postés vendredi 3 janvier 2014Date d'inscription 12 juillet 2017 Dernière intervention - 6 juin 2017 à 19:11
Merci ! =) mais du coup la fonction NB.SI>0 fonctionne donc j'avoue ne pas avoir essayé plus loin mais je suis sûr qu'elle fonctionnerai aussi ! =^.^=
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !