Signaler

Marges plus grandes et fond transparent [Résolu]

Posez votre question manchelo 284Messages postés jeudi 29 janvier 2009Date d'inscription 24 juin 2017 Dernière intervention - Dernière réponse le 9 juin 2017 à 13:47 par Dinath
Bonjour :)

suivant les thèmes que je choisi, il m'est toujours impossible de profiter d'une bonne largeur pour mes articles. Ces dits articles sont étroits.

En gros, sur un thème wordpress, il y a souvent un fond monochrome qui cache l'arrière plan et sur lequel, nos articles sont écrits. Généralement cela prend la moitié centre de la page. Mais les articles sont eux mêmes considérablement réduits dans ce bloc monochrome avec des marges tellement ahurissantes, que pour lire un article il faut mouliner la molette de la souris pendant des lustres.

Il faut apparemment modifier quelques lignes sur le style.css mais le code ne fait pas parti de mes points forts. (malgré un certain nombre de cours que je me suis payé).

Du coup, comment faire pour modifier la largeur de base d'un thème pour avoir des articles qui respirent un peu plus ?

Puis le 2eme point est que je n'aime pas ce principe de bloc qui nous cache l'arrière plan. Y'a t il un moyen de réduire son opacité ?


Voilà je sais pas si c'est très clair alors n'hésitez pas à me demander d'approfondir si ce n'est pas le cas :)

Merci d'avance pour vos réponses :)
Afficher la suite 
Utile
+1
plus moins
Salut !

Ca a pas l'air très compliqué, donne l'URL d'une page qu'on regarde :)
Donnez votre avis
Utile
+1
plus moins
On est mardi :)

Comment modifier son thème Wordpress ?

N'hésite pas à me dire si il te faut autre chose, normalement j'ai tout mis pour que tu puisses facilement t'y coller !

manchelo 284Messages postés jeudi 29 janvier 2009Date d'inscription 24 juin 2017 Dernière intervention - 7 juin 2017 à 15:34
div.post-content {
opacity: 0.5;
}

ça permet de diminuer le texte et les images, et non le fond.
Tout l'inverse de ce que je veux :)

Peut être y'a t il juste une ligne à corriger ?
div.content-background (oui je sais celui là n'existe pas XD)
Répondre
Dinath 1389Messages postés vendredi 12 avril 2013Date d'inscription Contributeur sécuritéStatut 27 juin 2017 Dernière intervention - 7 juin 2017 à 16:01
Je regarde tout cela ce soir après le taff ;-)
Répondre
manchelo 284Messages postés jeudi 29 janvier 2009Date d'inscription 24 juin 2017 Dernière intervention - 7 juin 2017 à 16:20
Merci beaucoup :)

Je suis en train de regarder pour les marges aussi :)

Peut être à ce soir alors :)
Répondre
Dinath 1389Messages postés vendredi 12 avril 2013Date d'inscription Contributeur sécuritéStatut 27 juin 2017 Dernière intervention - 7 juin 2017 à 16:28
Vire ton
opacity
, et tiens :

.post-container {
background: rgba(255, 255, 255, 0.5);
}
Répondre
manchelo 284Messages postés jeudi 29 janvier 2009Date d'inscription 24 juin 2017 Dernière intervention - 7 juin 2017 à 16:50
ça me rend fou ! J'avais testé ce code mais à chaque fois en mettant “background-color“ !

C'était en fait tellement plus simple... Pffff.

En tout cas merci pour ton coup de main :) ça fonctionne :)

Me reste plus qu'à trouver comment gérer les marges XD
Répondre
Donnez votre avis
Utile
-1
plus moins
1 - En fait pour être plus clair, je cherche à diminuer l'opacité de la zone de contenu pour que l'image d'arrière plan soit un peu visible.
Du genre :

opacity : 0.4;

2 - Et dans la zone de contenu, mes articles ne prennent qu'une petite place au centre. Les marges sont beaucoup trop grandes.
Du coup sur mon portefolio, toutes mes images miniatures sont superposées. Pas une seule n'est à côté d'une autre.

Peut être à modifier dans margin ou padding mais à quel endroit ? Post Content ?
Dinath 1389Messages postés vendredi 12 avril 2013Date d'inscription Contributeur sécuritéStatut 27 juin 2017 Dernière intervention - 7 juin 2017 à 22:55
C'est vraiment un conseil de merde c'est pas du tout là...

Enfin bon c'est pas grave tout va bien, tu t'es sûrement trompé dans wp-options ? C'est bien la bonne table en tout cas.

Check tes logs ?
Répondre
manchelo 284Messages postés jeudi 29 janvier 2009Date d'inscription 24 juin 2017 Dernière intervention - 8 juin 2017 à 00:07
Mes logs ?

Je vois ça où ?
Tu fais allusion aux révisions ?
Si c'est ça, j'ai tenté de revenir vers des versions antérieures mais sans résultat.


------------------------------------------
Edit :

Bon. ça remarche après avoir modifié les options de lecture dans les réglages.
Je comprends pas pourquoi... Mais au moins ça me calme les nerfs :)
Répondre
Dinath 1389Messages postés vendredi 12 avril 2013Date d'inscription Contributeur sécuritéStatut 27 juin 2017 Dernière intervention - 8 juin 2017 à 09:21
Non les logs du serveur web :)

Pour changer ta page d'acueil il faut aller dans Apparence > Personnaliser. Là tu fouilles un peu ;-)
Répondre
manchelo 284Messages postés jeudi 29 janvier 2009Date d'inscription 24 juin 2017 Dernière intervention - 8 juin 2017 à 09:22
Et pour les marges, ajouter cette ligne me parait pas mal :)

.post-inner {
width: 940px;
max-width: 100%;
}

Les valeur width et max-width sont bien sur à modifier selon les thèmes.

Voilà, je crois que cette fois c'est bon :)

Et Merci pour ton aide Dinath !
Répondre
Dinath 1389Messages postés vendredi 12 avril 2013Date d'inscription Contributeur sécuritéStatut 27 juin 2017 Dernière intervention - 9 juin 2017 à 13:47
Je t'en prie :)

Bon courage en tout cas ! Si tu as besoin d'un hébergeur, je serais dans le coin
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !