Signaler

Formules [Résolu]

Posez votre question André - Dernière réponse le 18 mai 2017 à 22:20 par Mike-31
Bonjour,
Je peine avec l'élaboration d'une formule. Quelqu'un peut il m'aider?

Dans A1, je voudrai copier une des valeurs de H1 ou M1 ou R1 en fonctions de leurs valeur.......

Si H1=0 et M1=0, copier la valeur de R1
Mais si, soit H1 ou M1 ont une valeur plus grande que 0, copier soit H1 ou M1
(Il n'y aura qu'une des trois cellules H1, M1 et R1 qui comportera une valeur supérieure à zéro)

Merci d'avance
André
Utile
+0
plus moins
Bonsoir

=SI(ET(H1=0;M1=0);R1;MAX(H1;M1))

crdlmnt
Donnez votre avis
Utile
+0
plus moins
Merci d'avoir répondu si vite. La formule ne fonctionne pas. J'ai peut-être mal formulé mon problème
Cordialement
Donnez votre avis
Utile
+0
plus moins
Merci beaucoup de votre réponse qui hélas ne fonctionne pas...
Ma formulation est peut-être pas précise
Cordialement
Vaucluse 20529Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 22 octobre 2017 Dernière intervention - 18 mai 2017 à 20:51
voyez ici, et si ça n'est pas ça que vous cherchez, dites nous ce qui ne va pas dans ce modèle
https://mon-partage.fr/f/epSTcK6O/
crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonsoir,

Désolé de te contredire, mais d'après ta demande la formule de l'ami Vaucluse que je salue répond exactement à la demande
si H1 et M1 affichent 0 la formule retourne la valeur contenue en R1
mais si H1 ou M1 contient une valeur autre que 0 la formule te retourne la valeur autre que zéro contenue dans une des deux cellules
Donnez votre avis
Utile
+0
plus moins
D'après le tableau téléchargé, il n'y a pas de valeur en M ou H.

Mon tableau aura toujours une valeur en H, M, R. (soit 2 cellules à 0 et 1 cellule avec un chiffre variable)

Dans mon problème, il y a trois possibilités
Exemple:

Si H=0, Si M=0, R aura une valeur supérieure à 1
Si H à une valeur supérieure à 1, M et R indiqueront zéro
Si M à une valeur supérieure à 1, H et R indiqueront zéro

Merci à vous
jordane45 18479Messages postés mercredi 22 octobre 2003Date d'inscription ModérateurStatut 23 octobre 2017 Dernière intervention - 18 mai 2017 à 21:19
Donc on confirme ... la formule donnée par Vaucluse fait exactement ce que tu demandes ....
As tu testé au moins ???

exemple de mise en situation de la formule :



Sinon.. poste-nous un fichier exemple avec tes différents cas ... et indique (dans une cellule à côté) le résultat espéré.
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour à tous,

Non seulement la formule répond à la demande mais l'on peut même la simplifier si 2 des cellules sont toujours à zéro
=MAX(H1;M1;R1)
Donnez votre avis
Utile
+0
plus moins
Désolé, mais ça ne fonctionne pas. Peut-être que, je vais chercher les valeurs sur un autre tableau (onglet différent) du même dossier.
Merci à vous
Donnez votre avis
Utile
+0
plus moins
Désolé, mais ça ne fonctionne pas.C'est Peut-être parce que, je vais chercher les valeurs sur un autre tableau (onglet différent) du même dossier.
Merci à vous
Donnez votre avis
Utile
+0
plus moins
Re,

ah et bien voila le hic, c'est comme si tu allais chercher la vaisselle dans l'armoire et le linge dans le vaisselier, il faut identifier ta feuille si elle est différente de la feuille ou se trouve la formule
=SI(ET(Feuil2!H1=0;Feuil2!M1=0);Feuil2!R1;MAX(Feuil2!H1;Feuil2!M1))
ou la formule de l'ami gbinforme que je salue
=MAX(Feuil2!H1;Feuil2!M1;Feuil2!R1)

à adapter bien sur si la feuille est nommée différemment de Feuil2
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
gbinforme 14222Messages postés lundi 18 octobre 2004Date d'inscription ContributeurStatut 23 octobre 2017 Dernière intervention - 18 mai 2017 à 22:17
Salut Mike
C'est plus facile de paramétrer une formule que de comprendre la demande ;-)
Tu ne dois pas être loin mais ce n'est pas 'Feuil2' mais 'zkpdqxw' qu'il aurait fallut mettre pour récupérer les valeurs ;-)
Répondre
Donnez votre avis
Utile
+0
plus moins
Un grand merci à vous tous. J'avais oublié que j'allais chercher mes données sur une autre feuille. Quel malin!!!!!!!!!!
Grâce à vos réponses, j'ai le choix des formules pour affiner mon tableau qui est un peu plus complexe que ça.
Désolé d'avoir gaspillé votre temps.
Très cordialement
Donnez votre avis
Utile
+0
plus moins
Re,

ce n'est pas grave mais on te fait parvenir nos factures rue du cherche après
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !