Recherche V [Résolu]

caro__48 259 Messages postés mercredi 14 avril 2010Date d'inscription 18 mai 2017 Dernière intervention - 18 mai 2017 à 13:12 - Dernière réponse : caro__48 259 Messages postés mercredi 14 avril 2010Date d'inscription 18 mai 2017 Dernière intervention
- 18 mai 2017 à 14:13
Bonjour,

Est-il possible de renommer le no_index_col dans une recherche V afin que celui ci ce base sur un nom et non un numéro de colonne?
Je m'explique:

J'ai deux tableaux: Stat & Recp_global

Dans mon tableau stat, je veux qu'en colonne B2 cela aille me chercher la valeur qui va correspondre dans un tableau recap_global en "21eme" position (no_index_col)
=RECHERCHEV($A2;Recap_global!$A$3:$V$116;21;FAUX)
MAIS
Je veux pouvoir rajouter des colonnes! Càd => Que dans un mois cela ne sera plus la 21 mais 22 eme positions.
Est-il possible de nommer cette colonne (actuellement 21) pour que ma formule face référence à un nom et pas une position?

J'espère que mon explication est compréhensible...

Merci d'avance pour votre aide :)


Afficher la suite 

2 réponses

Répondre au sujet
Mike-31 15899 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 15 décembre 2017 Dernière intervention - Modifié par Mike-31 le 18/05/2017 à 14:30
+1
Utile
1
Bonjour,

Si j'ai bien compris, oui bien sur, il suffit de nommer ta colonne
le 21éme correspond à la colonne U
tu clic sur l'entête et tu la nommes par exemple Cible
ta formule devient

=RECHERCHEV($A2;Recap_global!$A$3:$V$116;COLONNE(Cible);0)

de même si tu nommes ton tableau Recap_global!$A$3:$V$116 par exemple Tablo
la formule devient
=RECHERCHEV($A2;Tablo;COLONNE(Cible);0)
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Cette réponse vous a-t-elle aidé ?  
caro__48 259 Messages postés mercredi 14 avril 2010Date d'inscription 18 mai 2017 Dernière intervention - 18 mai 2017 à 14:13
Ah c'est ça en fait, j'avais bien renommer ma colonne mais je marqué le nom directement pas colonne(nom_colonne)!!

Oh punaise!! Merci beaucoup de ton aide!!
Commenter la réponse de Mike-31