Incrémentation de formule avec saut de cellules [Résolu]

sara-87 60 Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - 16 mai 2017 à 19:00 - Dernière réponse : sara-87 60 Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention
- 17 mai 2017 à 16:23
Bonjour,
Ma question a certainement déjà été posée mais je ne parviens pas à trouver une réponse.
Je dispose d'un tableau de données horaires avec 35066 lignes et 14 colonnes, et je voudrais réaliser la moyenne journalière pour chaque colonne en faisant un saut de 24 lignes ,comment pourrais-je dérouler la formule initiale exp: =moyenne(B2:B25) pour passer directement à =moyenne(B25:B50) pour la cellule suivante et non pas à =moyenne(B4:B26)...
J'ai essayée plusieurs manip avec la fonction DECALER mais je ne parviens toujours pas a trouver la bonne.

Si ma demande n'est pas très claire, voici un modèle : http://www.cjoint.com/c/GEqq5tSglrD

Merci d'avance pour vos réponses
Afficher la suite 
60Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention

9 réponses

Répondre au sujet
Hydr0s 1609 Messages postés lundi 24 janvier 2011Date d'inscription 8 décembre 2017 Dernière intervention - Modifié par Hydr0s le 16/05/2017 à 19:49
0
Utile
2
Salut,

Tu peux composer des formules avec la fonction INDIRECT(référence cellule). Dans ton cas, tes données sont dans la colonne B. Il faut que tu crée en D2 une case avec
1
en E2
=MOYENNE(INDIRECT("B"&D2*25-24&":B"&D2*25))
. En D3
=D2+1
et en étendant les formules, tu auras les moyennes des cases 1 à 25, 26 à 50 etc... Le & dans la formule permet de concaténer une chaîne de caractère. Si tes données commencent à B2, il faudra ajouter 1 partout.

Trust me and keep calm, I'm an engineer !
sara-87 60 Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - 16 mai 2017 à 22:14
Salut ,
Merci pour votre réponse,
j'ai galéré un peu pour comprendre mais c'est bon mon problème est résolu grâce a vous, j'ai juste une petite question ,si je veux faire le calcul dans une nouvelle feuille, est-ce possible ? j'ai essayée la formule suivante: =MOYENNE(INDIRECT("Feuil1!B"&Feuil1!$D2*25-24&":Feuil1!B"&Feuil1!$D2*25)) , mais cela renvoie l'erreur #REF ! ???
Hydr0s 1609 Messages postés lundi 24 janvier 2011Date d'inscription 8 décembre 2017 Dernière intervention - 16 mai 2017 à 22:41
INDIRECT("Feuil1!B"&Feuil1!$D2*25-24&":B"&Feuil1!$D2*25)
par exemple avec Feuil1 le nom de la feuille correspondante (un feuille en trop)
Commenter la réponse de Hydr0s
Mike-31 15889 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - 16 mai 2017 à 22:43
0
Utile
Bonsoir,

tu peux faire directement et sur n'importe quelle feuille avec ce genre de formule
si ta première formule est sur la ligne2 tu insères dans la formule la syntaxe LIGNE() qui te donnera l'index de la ligne, soit 2-1 ce qui te donnera 1 si ta première formule est sur la ligne 10 la syntaxe sera LIGNE()-9
incrémente la formule vers le bas
=MOYENNE(INDIRECT("B"&(LIGNE()-1)*25-24&":B"&(LIGNE()-1)*25))

de même si tu dois incrémenter comme sur ton fichier la formule vers la droite on utilisera de la même manière la syntaxe COLONNE() et pour la première formule colonne P
=MOYENNE(INDIRECT("B"&(COLONNE()-15)*25-24&":B"&(COLONNE()-15)*25))

Commenter la réponse de Mike-31
eriiic 21188 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - Modifié par eriiic le 16/05/2017 à 22:52
0
Utile
Bonjour,

elle était presque bonne ta formule, il manque juste un $. En B2 :
=SIERREUR(MOYENNE(DECALER(Donnees!B$2;24*(LIGNE()-2);;24;));"")

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Commenter la réponse de eriiic
Mike-31 15889 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - Modifié par Mike-31 le 16/05/2017 à 23:21
0
Utile
2
Salut Eriiic,
Ah oui Joli, bien vu
Bonne nuit
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
eriiic 21188 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - 16 mai 2017 à 23:59
Dommage que je ne l'ai vu qu'après avoir construit la mienne ;-)
Bonne nuit également
Hydr0s 1609 Messages postés lundi 24 janvier 2011Date d'inscription 8 décembre 2017 Dernière intervention - 17 mai 2017 à 08:26
Cool, je connaissais pas ces fonctions ;)
Commenter la réponse de Mike-31
sara-87 60 Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - 17 mai 2017 à 16:23
0
Utile
c'est vraiment génial !! un grand Merci à vous tous ;-)
Commenter la réponse de sara-87