Signaler

Problème avec formule SOMME.SI.ENS [Résolu]

Posez votre question Red2016 4Messages postés samedi 13 mai 2017Date d'inscription 14 mai 2017 Dernière intervention - Dernière réponse le 14 mai 2017 à 17:57 par Red2016
Bonjour,

J'ai un planning d'où j'aimerai reprendre les heures prestée par les ouvriers sur les différents chantiers.

J'ai un tableau qui me comptabilise le nombre d'heure par chantier dans l'onglet "Récapitulatif Chantier"(cela fonctionne)

Par contre pas moyen avec la fonction
=SOMME.SI.ENS(Planning!$F$6:$AS$30;Planning!$E$6:$AR$30;A2;Planning!$B$6:$AO$30;$B$1)

de récupérer la somme total des heures par ouvrier.


Je vous joint le fichier

https://mon-partage.fr/f/eUJML6LZ/

Merci pour votre aide

Afficher la suite 
Utile
+0
plus moins
Bonsoir Red

Essaie en B2 la formule :
=SOMME.SI.ENS(DECALER(Planning!$F$6:$AS$10;5*(EQUIV(B$1;$B$1:$F$1;0)-1););DECALER(Planning!$E$6:$AR$10;5*(EQUIV(B$1;$B$1:$F$1;0)-1););$A2)
à étirer ensuite vers la droite et vers le bas

Cdlmnt
Via
Red2016 4Messages postés samedi 13 mai 2017Date d'inscription 14 mai 2017 Dernière intervention - 14 mai 2017 à 10:32
Bonjour via55,

Un grand merci, cela fonctionne dans mon exemple.

Par contre j'ai dans un planning officiel qui reprends toute l'année et tous le personnel (50 personnes +-).

Et en adaptant ta formule cela ne fonctionne pas.

Il me calcul tous les heures ?

Cordialement
Répondre
via55 7830Messages postés mercredi 16 janvier 2013Date d'inscription 15 mai 2017 Dernière intervention - 14 mai 2017 à 11:59
Bonjour Red

N'ayant pas en main ton planning officiel je ne peux pas dire ce qui cloche !

Ma formule est bâtie sur ton exemple qui comporte 5 lignes par salarié d'où le 5 dans la formule, si le réel est conçu différement il faut adapter

Cdlmnt
Via
Répondre
Red2016 4Messages postés samedi 13 mai 2017Date d'inscription 14 mai 2017 Dernière intervention - 14 mai 2017 à 12:20
Re ;

J'ai trouver mon erreur dans la formule par contre tu pourrais me dire à quoi correspond le nombre '5' ?

=SOMME.SI.ENS(DECALER('2017'!$L$6:$AQD$10;5*(EQUIV(B2;$B$2:$B$37;0)-1););DECALER('2017'!$K$6:$AQC$10;5*(EQUIV(B2;$B$2:$B$37;0)-1););$D$1)

Nombre de ligne par ouvrier ?

Car dans mon tableau officiel les heures ne sont pas correct et sont décalée ?

Ex: les heures de smit2 sont sur smit1 et le total n'est pas correct.

Cordialement
Répondre
via55 7830Messages postés mercredi 16 janvier 2013Date d'inscription 15 mai 2017 Dernière intervention - 14 mai 2017 à 13:54
Re

Oui 5 correspond au nombre de lignes par ouvrier comme je te le disais dans mon message 3
Il faut évidemment que ce nombre soit identique pour chaque ouvrier

Une autre solution serait de faire les totaux dans planning et de les transposer ensuite :
exemple dans Decompte personnel 2 : https://mon-partage.fr/f/ubcPIOez/

Cdlmnt
Répondre
Red2016 4Messages postés samedi 13 mai 2017Date d'inscription 14 mai 2017 Dernière intervention - 14 mai 2017 à 17:57
Super via55, ta formule fonctionne à merveille.

Je suis autodidacte, j'aurais du analyser ta formule avant.

J'ai du personnel en contrat chantier dont je masque les lignes quand il ne travaille pas et comme les noms repris dans mon décompte sont en liaison par rapport au planning tout était décalé.

Un grand merci à toi
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !