Signaler

Compter les nombres des numéro identique pour chaque line. [Résolu]

Posez votre question Maximus.001 5Messages postés samedi 13 mai 2017Date d'inscription 13 mai 2017 Dernière intervention - Dernière réponse le 13 mai 2017 à 22:20 par Maximus.001
Bonjour,
Je suis nul en Excel.
J’ai essayé de trouver quelque chose avant de pose la question mais je n’ai pas réussi.
Je me suis rendu compte que l’Excel est très complexe pour moi.
Donc je pose la question :
J’ai une base de données de 9000 lignes.
Chaque line a 20 cellules.
Chaque cellule contient un numéro du 1 à 70.
A l’intérieur de chaque ligne les numéros ne s’est répètent pas.
J’ai une autre ligne avec les mêmes caractéristiques décrites en haut (20 numéros du 1 à 70 qui ne s’est répètent pas).Je l’appelle la ligne test
Quelle formule je pourrais appliquer pour compter combiens des numéros s’est répètent dans chaque ligne de ma base de données en utilisant la ligne test?
Afficher la suite 
Utile
+0
plus moins
Bonjour.

Peut-être avec la fonction SOMMEPROD ...
Donnez votre avis
Utile
+0
plus moins
Bonjour
pas tout compris, mais je tente

votre ligne de référence de A1 à T1
votre tableau démarre de A2 à Txxx

en B2, à tirer sur le nombre de lignes:

=SOMMEPROD(($A$1:$T$1=A2:T2)*1)

attention aux signes $

cette formule vous donnera le nombre de N° dans chaque ligne qui se retrouve en A1:T1

crdlmnt
Maximus.001 5Messages postés samedi 13 mai 2017Date d'inscription 13 mai 2017 Dernière intervention - 13 mai 2017 à 17:23
Bonjour,
Chapeau pour ceux qui donnent du leur temps pour aider les autres!
C’est peut-être la bonne réponse mais je n’ai pas réussi à l’appliquer jusqu'à la fin.
J’ai clique sur B2 dans mon tableau, après j’ai clique sur insérer une fonction, j’ai choisi SOMMEPROD, après j’ai écrit sur le premier champ (Matrice 1) $A$1 :$T$1 et après je n’ai sait pas comment continuer…
Répondre
Raymond PENTIER 42588Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 26 juin 2017 Dernière intervention - 13 mai 2017 à 17:47
Fais juste un copier-coller de la formule de Vaucluse, ou bien recopie-la au clavier.
Répondre
Vaucluse 19802Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 26 juin 2017 Dernière intervention - 13 mai 2017 à 18:51
Ne passez pas par insertion fonction, tapez au clavier simplement

placez le curseur dans la cellule et en vérifiant bien tous les signes:

=SOMMEPROD(($A$1:$T$1=A2:T2)*1)

faites enter

et ensuite sélectionnez la cellule et son petit carré noir qui apparait en bas à droite
maintenez le clic et faire glisser sur la hauteur utile
crdlmnt
Répondre
Maximus.001 5Messages postés samedi 13 mai 2017Date d'inscription 13 mai 2017 Dernière intervention Raymond PENTIER - 13 mai 2017 à 20:17
Bonjour,
Merci pour votre patience.
Première fois j’ai clique sur B2 comme Vaucluse disait après j’ai déposé la formule avec copier-coller mais ça a rien donne, après j’ai fait la même chose mais sur une cellule vide par exemple U1 mais le résultat n’est pas exact.
J’explique :par exemple j’ai 2 lignes ; la ligne test et la première ligne du ma base de données.
2,7,8,12,14,21,25,28,30,31,33,34,36,38,43,46,51,57,63,68
3,4,8,29,40,42,44,45,47,48,49,50,57,58,60,61,63,65,67,68
Si je compare le 2 lignes manuellement je vois que j’ai 4 numéros communs.
La formule me donne seulement 2 numéros.
Je ne sais pas comment corriger la formule ou peut-être j’ai fait une erreur quelque part.
Cordialement,
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour à tous les trois

> Vaucluse. J'ai utilisé ta formule (ligne test 2, ligne à tester 3)
=SOMMEPROD(($A$2:$T$2=A3:T3)*1)
mais malgré mon acharnement à la retaper, elle ne me dénombre que les cellules qui ont la même valeur dans la même colonne .... je dois louper quelque chose ou alors, c'est mon antique excel 2003 qui fatigue ;-)

Du coup, j'y suis allé carrément avec une macro qui a l'avantage de ne pas encombrer/ralentir le fichier (de 9000 lignes quand même ...)
http://www.cjoint.com/c/GEnq4RzF3IH

Cdlmnt
Vaucluse 19802Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 26 juin 2017 Dernière intervention - 13 mai 2017 à 19:35
Salut CCM, effectivement je me suis laissé un peu aller là, on est samedi!
Aller, on corrige, toujours sans VBA

=SOMMEPROD((NB.SI($A$1:$T$1;A2:T2)*1)

soit ça, donc
https://mon-partage.fr/resume/rijKe/
crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,
Excellent, ça marche nickel ta formule Vaucluse, merci beaucoup à tous!
Mais si j’aurais une ligne test de 15 numéros ou 25 je crois que la formule change parce-que d’auprès que j’ai lit pour appliquer SOMMEPROD il faut avoir des matrices égales?
Cordialement,

Vaucluse 19802Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 26 juin 2017 Dernière intervention - 13 mai 2017 à 20:44
Non, dans ce cas, en passant par NB.SI,le nombre de références peut être différent de celui des champs à analyser, mais il ne faut pas de cellule vide dans la liste des références

elle peut même fonctionner avec une plage de plusieurs lignes à analyser
=SOMMEPROD(NB.SI($A$1:$E$1=A2:T20)
crdlmnt
Répondre
Maximus.001 5Messages postés samedi 13 mai 2017Date d'inscription 13 mai 2017 Dernière intervention - 13 mai 2017 à 22:20
Bonjour,
Merci encore une fois pour tout ton aide. C’est très apprécié!
Cordialement,
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !