Signaler

Comparaison de 2 colonnes dans 2 sheets (excel) [Résolu]

Posez votre question wis1990 23Messages postés lundi 6 mars 2017Date d'inscription 28 août 2017 Dernière intervention - Dernière réponse le 14 mai 2017 à 13:52 par wis1990
Bonjour,

j'ai une colonne A qui contient dans la feuill 1
LB1
LB2
LB1
LB3
KG1
KG2
KG
...

dans la colonne A dans la feuill 2

LB1
LB2
LB3
KG
KG1
KG2
dans la feuill 1 y'a une colonne comp
je dois comparer ces 2 colonnes si dans la feuill 1 une personne enregistre lb1, comme y'a pas de lb1 dans la table de la feuill 2
dans la colonne comp, je devrais retourné faux comme valeur et vrai si c'est correct.j'ai déjà essayé avec "SI(test_logique;valeur si vrai, valeur si faux)" mais ca ne marche pas,je n'ai que des faux. il me faut un peu d'aide.

Cordialement,

Wis.
Utile
+0
plus moins
Bonjour

Essayer ceci en B2 feuille 1

=SI(A2="";"";SI(SIERREUR(RECHERCHEV(A2;Feuil2!$A$1:$B$100;1;FAUX);"")=A2;"";"faux"))

Tirer la formule sur les 100 première lignes
Donnez votre avis
Utile
+0
plus moins
je ne comprends pas trop bien la formule entre les guillemets y'a quoi
PHILOU10120 4560Messages postés lundi 16 avril 2012Date d'inscription 19 septembre 2017 Dernière intervention - 12 mai 2017 à 20:40
rien c'est pour tester une cellule vide
Répondre
wis1990 23Messages postés lundi 6 mars 2017Date d'inscription 28 août 2017 Dernière intervention - 12 mai 2017 à 21:15
ca ne fonctionne pas
Répondre
Donnez votre avis
Utile
+0
plus moins
J'ai essayé avec VLOOKUP elle me renvoie que des #N/A mais ne fait pas ce que je lui demande.
Donnez votre avis
Utile
+0
plus moins
Bonjour Wis1990

Le détail de la formule

La première Fonction SI(...)

=SI(A2="";"";SI(SIERREUR(RECHERCHEV(A2;Feuil2!$A$1:$B$100;1;FAUX);"")=A2;"";"faux"))

Contrôle si la cellule A2 n'est pas égale à vide "" et si oui elle n'affiche rien ""

La Fonction RECHERCHEV

=SI(A2="";"";SI(SIERREUR(RECHERCHEV(A2;Feuil2!$A$1:$B$100;1;FAUX);"")=A2;"";"faux"))

RECHERCHEV(...) cherche A2 en colonne A de la feuil2 et renvoie la valeur exact de la colonne B (FAUX = valeur exacte VRAI = valeur approchante)


La fonction SIERREUR(...)

=SI(A2="";"";SI(SIERREUR(RECHERCHEV(A2;Feuil2!$A$1:$B$100;1;FAUX);"")=A2;"";"faux"))

SIERREUR(...)évite l'affichage d'erreur dans le cas ou la recherchev ne trouve pas la valeur en colonne A de la feuil2

La fonction SI(...)

=SI(A2="";"";SI(SIERREUR(RECHERCHEV(A2;Feuil2!$A$1:$B$100;1;FAUX);"")=A2;"";"faux"))

Fonction SI(...) si la recherchev et si "sierreur " = A2 n'affiche rien "" sinon affiche "faux"

Bonne journée

Donnez votre avis
Utile
+0
plus moins
bonjour

formule test de comparaison à adapter au contexte

en 1° ligne (1 pour l'exemple)
=NB.SI(Feuil2!A1:A40;A1)>0
à tirer vers le bas

ne tient pas compte de la casse, nombre de lignes feuil1>= feuil2

la démo
https://mon-partage.fr/f/Vh2psmGK/


wis1990 23Messages postés lundi 6 mars 2017Date d'inscription 28 août 2017 Dernière intervention - 14 mai 2017 à 07:44
Bonjour,
y'en a d'autres feuilles mais je fais la comparaison de deux pensez que c'est en la cause quand je n'ai que des faux quoique c vrai. j'ai oubliee de dire que c'est dans un tableau

je suis vraiment bloquee vous pouvez m'aider svp. je dois le remettre demain
Répondre
wis1990 23Messages postés lundi 6 mars 2017Date d'inscription 28 août 2017 Dernière intervention - 14 mai 2017 à 08:22
plusieurs feuilles n'est pas le prob je viens de cree un autre classeur et ca marche mais pas dans le vrai rapport. et je ne comprends rien . pensez-vous que c'est un probleme si ses colonnes sont une combinaison parce que g utilise la formule (=A1&" "&B1) pour avoir les deux colonnes que je dois comparer est-ce possible de faire avec ?

je dois le remettre demain et je suis vraiment coincee. un peu d'aide svp.
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonsoir,

@PHILOU ca ne marche pas jusqu'a maintenant.

@Michel elle ne me retourne que des faux.
Donnez votre avis
Utile
+0
plus moins
Lorsque tu demandes de l'aide, le minimum est d'être clair, précis et complet


Donnez votre avis
Utile
+0
plus moins
Desolee

J'ai un classeur d'excel avec plusieurs feuilles, mais je dois comparer 2 colonnes l'une dans donnees et l'autre dans dictio.
j'ai fait fait la combinaison de 2 ou 3 colonnes pour la comparaison , est-ce possible de comparer 2 colonnes combinés. j'ai essayé cette formule "=NB.SI(Feuil2!A1:A40;A1)>0" dans des colonnes simples ca a marché mais quand c une combinaison rien du tout. si vous pouvez m'aider je vous en remercie.

ex:

Donnees Dictio
A B C D E A B C D

D=A1&""&B1&""&C1 D=A1&""&B1&""&C1

Si D dans donnees se trouve dans D dans dictio je dois avoir vrai dans la colonne E dans donnees. mais je ne sais pas si c la combinaison qui en est la cause ou pas ca ne marche pas.
wis1990 23Messages postés lundi 6 mars 2017Date d'inscription 28 août 2017 Dernière intervention - 14 mai 2017 à 13:40
la combinaison n'est pas un probleme je viens de le remarquer j'ai les resultats voulu dans la feuille dictio mais quand je transfere la formule dans une colonne ds la feuille donnee c erreur tout simplement.
Répondre
Donnez votre avis
Utile
+0
plus moins
enfin ca fonctionne
merci pour votre aide

Cordialement wis.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !