Différence heure [Résolu]

Ellivech - 11 mai 2017 à 11:40 - Dernière réponse : Mike-31 15887 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention
- 11 mai 2017 à 15:14
bonjour à tous,

j'avais déjà trouver la formule dans le forum il y a quelque temps mais je ne la retrouve pas désolé.

je travail sur le temps de travail du personnel.
j'ai un forfait : 10:00 par exemple
et un réel fait par l'employé : 09:45
et un autre employé : 10:45

pour l'un la soustraction fonctionne et pour l'autre je me retrouve avec #####

Merci d'avance pour votre réponse :)
Afficher la suite 

7 réponses

Répondre au sujet
Mike-31 15887 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 11 mai 2017 à 12:09
+2
Utile
1
Bonjour

regarde comme cela
=MOD(B2;A2)

mais pour que la formule fonctionne dans les deux sens
=SI(A2>B2;A2-B2;MOD(B2;A2))

mais pour afficher des heures négatives il faut passer avec le calendrier 1904 qui pose problème avec les liaisons avec d'autres fichiers
ou avec cette formule mais le résultat sera au format texte et donc ne pourra rentrer dans un mode de calcul
=SI(A2>B2;A2-B2;"-"&TEXTE(MOD(B2;A2);"hh:mm:ss"))
Cette réponse vous a-t-elle aidé ?  
Super merci !!
Ca fonctionne :)

Par contre comment je peux faire pour mettre la case d'une couleur lorsque le résultat aurai dû être en négatif ?
Commenter la réponse de Mike-31
jc80 3866 Messages postés mardi 5 février 2013Date d'inscription 12 décembre 2017 Dernière intervention - 11 mai 2017 à 12:06
+1
Utile
1
Bonjour

exemple avec en A1 l'horaire normal et en B1 les heures effectuées

=SI(A1<B1;"- "&TEXTE(-(A1-B1);"[h]:mm");A1-B1)
Cordialement
jc80 3866 Messages postés mardi 5 février 2013Date d'inscription 12 décembre 2017 Dernière intervention - 11 mai 2017 à 13:48
Formule réctifiée
=SI(B1<A1;"- "&TEXTE(-(B1-A1);"[h]:mm");B1-A1)
Commenter la réponse de jc80
Mike-31 15887 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - Modifié par Mike-31 le 11/05/2017 à 15:14
+1
Utile
Re,

pour mettre en couleur ta cellule il faut utiliser la mise en forme conditionnelle

pour comprendre, restons sur tes explications, quand veux tu coloriser ta cellule, lorsqu'elle affiche 00:15
ou une valeur négative -00:15

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Commenter la réponse de Mike-31
missgg007 27 Messages postés mercredi 12 juin 2013Date d'inscription 11 mai 2017 Dernière intervention - 11 mai 2017 à 11:49
0
Utile
Bonjour,
il a peut être un problème de taille de police !
Commenter la réponse de missgg007
0
Utile
Salut missgg007

Non ce n'est pas un problème de police je viens de vérifier :/

La simple soustraction fonctionne lorsque le forfait est supérieur au réel :

10:00 - 9:45 = 00:15

Logiquement si je fais l'autre :
10:00 - 10:45 je devrais avoir -00:45
Commenter la réponse de Ellivech