Signaler

Problème avec fonction recherchev [Résolu]

Posez votre question dynomax80 3Messages postés mardi 9 mai 2017Date d'inscription 9 mai 2017 Dernière intervention - Dernière réponse le 9 mai 2017 à 11:55 par dynomax80
Bonjour,

Voici mon soucis.

Je veux utiliser une fonction recherchev qui va chercher un nom qui est donné via une liste déroulante dans plusieurs tableau (une fonction par tableau).

Hors selon les nom choisi, soit j'ai la bonne valeurs, soit ça me met N/#A quand la cellule est vide (alors que si la case d'origine est vide, il devrait me mettre rien) et quand la cellule est correspond avec la cellule de la liste déroulante, il me met soit N/#A ou soit la valeur du tableau.

Je ne comprend pas pourquoi cela ne marche pas. Est-ce que c'est parce que les valeurs recherché sont des valeurs copié avec liaisons ?

voici ma formule : =SI($C$3="";"";RECHERCHEV($C$3;casse;2;FAUX))



Merci d'avance pour vos réponses



Utile
+0
plus moins
Bonjour
sans votre modèle, ça va être difficile de vous aider
mais:
si la cellule C3 est vide, la fonction RECHERCHEV renvoi systèmatiquement #N/A
si autrement la formule renvoie #N/A c'est qu'elle ne trouve pas le nom dans la première colonne du champ casse
amis comme vous parlez de plusieurs tableaux, quels sont les autres?*
Pour faciliter , pouvez vous déposer un modèle ici:
httyps://mon-partage.fr
et revenir coller le lien créé sur le site

en attendant , pour info à tut hasard, si vous avez plusieurs tableaux, (3 dans cet exemple) la formule peut s'écrire:

=RECHERCHEV(C3;SI(NB.SI(1° col tab1;C3);Tab1;SI(NB.SI(1° colonne Tab 2;C3);Tab2;Tab3));2;0)

à vous lire

crdlmnt


dynomax80 3Messages postés mardi 9 mai 2017Date d'inscription 9 mai 2017 Dernière intervention - 9 mai 2017 à 11:04
Bonjour,
Je ne peux pas pour le moment partager le fichier, les sites ont du mal a charger ici.

Pour résumer ce que la formule doit faire, c'est en fonction d'un nom que donne une liste déroulante (ici en C3) elle va chercher dans un tableau (2 colonnes, 10 lignes) si le nom apparait et si celui ci apparait (colonnes 1), la fonction doit afficher ce qu'il y a en colonne 2. Et si la colonne 1 ne contient pas le nom, la recherche n'affiche rien.

Est-ce que cela vous aide ?

Cordialement
Répondre
Donnez votre avis
Utile
+0
plus moins
Si votre tableau s'appelle bien casse et que vus cherchez bien la valeur de C3 dans la 1° colonne de ce tableau, il n'y a pas de raison que votre formule

=SI($C$3="";"";RECHERCHEV($C$3;casse;2;FAUX))

pose problème, sauf si la valeur C3 n'existe pas dans la 1° colonne

Vérifiez le format de cellule, si les valeurs ne comporte pas un blanc de trop ou autre, bref, vérifiez que vous avez bien le même type de valeur en C3 et dans le champ de recherche

Je ne vois pas ce qu'il peut y avoir d'autre comme problème
dynomax80 3Messages postés mardi 9 mai 2017Date d'inscription 9 mai 2017 Dernière intervention - 9 mai 2017 à 11:55
c'était bien les espaces en trop dans le tableau d'origine qui faussait la recherche.
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !