Signaler

Addition de cellules sans doublon [Résolu]

Posez votre question xeug 29Messages postés jeudi 14 janvier 2016Date d'inscription 9 mai 2017 Dernière intervention - Dernière réponse le 9 mai 2017 à 10:25 par xeug
Bonjour,
Dans une colonne j'ai des n° de bon représentant des commandes.
10;11;12;12;13;14...
Le problème c'est que je peux avoir deux même n° de bon représentant des articles différents sur la même commande.
Je voudrais savoir le nombre de commande (dans l'exemple ci dessus 5 et non 6).
Merci.
Afficher la suite 
Utile
+0
plus moins
Bonjour
le n° de commande dans A1:A30

=SOMMEPROD(1/NB.SI(A1:A30;A1:A30))
Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule. La formule est alors encadrée automatiquement par des accolades : { formule }
Patrice33740 5934Messages postés dimanche 13 juin 2010Date d'inscription 29 juin 2017 Dernière intervention - 9 mai 2017 à 08:37
Bonjour Michel,

Bien vu, mais le PROD n'est pas nécessaire :
=SOMME(1/NB.SI(A1:A30;A1:A30))
en matriciel fonctionne aussi.

Cdlt
Patrice
Répondre
xeug 29Messages postés jeudi 14 janvier 2016Date d'inscription 9 mai 2017 Dernière intervention - 9 mai 2017 à 10:25
Que de solutions...
Et cela fonctionne
Merci.
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

Dans une autre colonne :
=NB.SI($A$1:$A1;A1)=1

à tirer vers le bas
Puis faire la somme de cette colonne
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !