Signaler

Ajustement de la fonction ARRONDI [Résolu]

Posez votre question max33d - Dernière réponse le 9 mai 2017 à 10:49 par Vaucluse
Bonjour à tous,

J'aimerais savoir si il est possible de "modifier" la fonction ARRONDI pour un cas précis.
Je m'explique :
- Il faudrait que la fonction arrondisse au nombre inférieur lorsque les chiffres après la virgule vont de 1 à 5 et au nombre supérieur lorsque les chiffres après la virgule vont de 6 à 9.
Exemple : 6.1 --> 6
6.5 --> 6
6.8 --> 7
Dans la fonction ARRONDI actuelle 6.5 est arrondit à 7.
J'espère avoir été clair, merci de votre aide !

Max
Afficher la suite 
Utile
+0
plus moins
Bonjour
=SI(A2>6,5;ARRONDI(A2;0);ARRONDI.INF(A2;0))
Donnez votre avis
Utile
+0
plus moins
Bonjour,

Merci de votre réponse.
J'ai mis un exemple pour 6, 6.5, 6.8 mais les valeurs peuvent varier de 0.1 à 10.
Donnez votre avis
Utile
+0
plus moins
Bonjour
pour adapter ça à une valeur variable dans une cellule A1:

=SI(A1-ENT(A1)=0,5;ARRONDI.SUP(A1;0);ARRONDI(A1;0))

crdlmnt
Donnez votre avis
Utile
+0
plus moins
re
=SI(A2-ENT(A2)>0,5;ARRONDI(A2;0);ARRONDI.INF(A2;0))
max33d- 9 mai 2017 à 09:57
Merci à tous !
Répondre
Vaucluse 19844Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 28 juin 2017 Dernière intervention - 9 mai 2017 à 10:49
Pas de quoi, je passe le sujet en résolu
bonne route
crdlmnt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !