Signaler

Nombre de mois entre 2 dates d'un exercice fiscal particulier

Posez votre question dalisse - Dernière réponse le 21 avril 2017 à 12:04 par dalisse
Bonjour,

Je dois présenter mon Chiffre d'Affaire sur chaque exercice fiscal, depuis 2014.
Mes exercices fiscaux sont :
1ier juillet 2014 / 20 juin 2015
1ier juillet 2015 / 20 juin 2016
1ier juillet 2016 / 20 juin 2017
1ier juillet 2017 / 20 juin 2018

J'ai des périodes de facturation différentes, de type :
- Du 07 mars 2014 au 20 décembre 2014 : soit, sur 2 exercices fiscaux.
- Des montants mensuels identiques mensuellement pour chaque client. X paye 500, y page 700, z paye 800...

J'avais fait un tableau avec des variables avec les périodes sur mes exercices fiscaux, pour obtenir le nombre de mois, et en ressortir des formules de type =SI(F42="";"";SI(G42="";"";((ANNEE(SI(G42>Variables!$B$2;Variables!$B$2;G42))-ANNEE(SI(F42<Variables!$B$1;Variables!$B$1;F42)))*12)+(MOIS(SI(G42>Variables!$B$2;Variables!$B$2;G42))-MOIS(SI(F42<Variables!$B$1;Variables!$B$1;F42)))))
Ensuite, je multiplie le nombre de mois à mon montant mensuel pour obtenir mon CA

F42 : date de début (07/03/2014 par exemple)
G42 : date de fin (20/12/2014 par exemple)
Variables!$B$2 : 01/07/2014
Variables!$B$1 : 30/06/2015

Toutefois, cela fonctionne bien la première année, mais :
- Il compte les mois complets, du premier au 31, ce qui m'enlève du CA sur certaines périodes.
- Il m'indique un nombre de mois, même lorsque c'est sur l'exercice fiscal suivant. Alors qu'il devrait me mettre 0, et me mettre le nombre dans la colonne dédié à l'exercice fiscal à côté.

J'espère être assez clair.

Merci pour votre aide.



Utile
+0
plus moins
Bonjour,

Pour obtenir ton CA tu devrais plutôt utiliser SOMMEPROD
=SOMMEPROD((date de début>=Variables!début)*(date de fin<=Variables!fin)*montant)
Donnez votre avis
Utile
+0
plus moins
bonjour
une piste

=SOMMEPROD($A$3:$A$14>=D3;$A$3:$A$14<=E3;$C$3:$C$14)
Donnez votre avis
Utile
+0
plus moins
Merci pour votre retour mais ça n'a pas fonctionné.
J'ai bidouillé pour trouvé une réponse, en mettant du +1 sur mes mois pour les rendre complet.
Et en travaillant beaucoup à la main.
Le résultat est là, peut être pas propre, mais il est là.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !