Mfc suivant texte dans une formule concatené [Résolu]

christophedir 119 Messages postés vendredi 18 novembre 2016Date d'inscription 16 décembre 2017 Dernière intervention - 17 avril 2017 à 09:44 - Dernière réponse : christophedir 119 Messages postés vendredi 18 novembre 2016Date d'inscription 16 décembre 2017 Dernière intervention
- 17 avril 2017 à 11:01
EXCEL 2013

Bonjour,

sur mon tableau une cellule A1 contient le texte issue de deux cellules d'un autre tableau,

l'une de ces cellules contient 4 possibilité
exemple : ab, tc ,re,ou vides.
1) Je voudrais que si l'une des trois proposition de texte ce trouve dans A1 je puisse mettre une couleur
2 ) serait-il possible d'avoir une couleur différente par texte?

Je voudrais si possible pouvoir avoir les deux cas car je ne suis pa le seul pour décider.

Cordialement

Et Joyeuses Pâques
Afficher la suite 

3 réponses

Répondre au sujet
gbinforme 14436 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - 17 avril 2017 à 10:14
0
Utile
Bonjour,

1) si l'une des trois proposition de texte ce trouve dans A1
=SOMME((NON(ESTERREUR(TROUVE("ab";A1))))+(NON(ESTERREUR(TROUVE("re";A1))))+(NON(ESTERREUR(TROUVE("tc";A1)))))

2 ) une couleur différente par texte
=NON(ESTERREUR(TROUVE("ab";A1)))

autant de MFC que de couleurs / codes
Commenter la réponse de gbinforme
Vaucluse 20872 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - Modifié par Vaucluse le 17/04/2017 à 10:16
0
Utile
Bonjour
Difficile de savoir avec votre message si votre texte à détecter et seul dans la cellule ou inclus dans un autre?
alors deux options (Excel à partir de 2007)

sélectionnez le champ à traiter (pour l'exemple commence en A1 et peut aller jusqu'à xxx)

icône mise en forme conditionnelle
"nouvelle règle"
dans la fenêtre choisir "utiliser une formule"

entrez la formule, si le texte est inclus dans un autre:
=NB.SI(A1;"*ab*") attention aux signes

ou si le texte est seul:
=A1="ab"

clic sur format / formatez/ OK

vous revenez à la fenêtre de MFC:

"nouvelle règle"
recommencez avec les autres textes et les formats différents
fermez tout par OK

Notes:
  • entrez la formule qui correspond à la 1° du champ la MFC va s'adapter automatiquement à la sélection
  • Si vous avez plusieurs textes de référence détectés dans la cellule, c'est la 1° MFC qui fonctionnera. Vous pouvez classer les MFC dans la fenêtre avec les flèches ascenseur pour définir des priorités


crdlmnt




La qualité de la réponse dépend surtout de la clarté de la question, merci!
Commenter la réponse de Vaucluse
christophedir 119 Messages postés vendredi 18 novembre 2016Date d'inscription 16 décembre 2017 Dernière intervention - 17 avril 2017 à 11:01
0
Utile
Merci à vous duex d'avoir répondu
Commenter la réponse de christophedir