Signaler

Cups/samba

Posez votre question kaireh - Dernière réponse le 9 mai 2017 à 12:14 par mamiemando
Bonjour,

serveur cups "page limit ne fonctionne pas"
j'aimerais avoir une solution cher(e)s collegues
merci de vos collaboration
Afficher la suite 
Utile
+0
plus moins
Bonjour,

Il faudrait nous dire plus précisément ce que tu as fait (configuration actuelle, commandes lancées...).

As-tu essayé ceci par exemple ?
https://www.cups.org/doc/accounting.html

Bonne chance
Donnez votre avis
Utile
+0
plus moins
----------------printers.conf-----------
# Printer configuration file for CUPS v1.5.3
# Written by cupsd
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<Printer crisa>
UUID urn:uuid:9052f6c8-146a-3851-7c31-f507778be1ae
Info HP LaserJet P2055dn
Location cris
MakeModel HP LaserJet p2055d hpijs pcl3, 3.12.2
DeviceURI socket://172.32.172.3:9100
State Idle
StateTime 1492671172
Reason toner-empty-warning
Type 8425500
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 60
PageLimit 2
KLimit 0
AllowUser samod
OpPolicy default
ErrorPolicy retry-job
Attribute marker-colors none
Attribute marker-levels 0
Attribute marker-names Black Cartridge HP CE505A
Attribute marker-types toner
Attribute marker-change-time 1492671172
</Printer>

----------------------cupd.conf-------------
#
#
# Sample configuration file for the CUPS scheduler. See "man cupsd.conf" for a
# complete description of this file.
#

# Log general information in error_log - change "warn" to "debug"
# for troubleshooting...
LogLevel warn

# Deactivate CUPS' internal logrotating, as we provide a better one, especially
# LogLevel debug2 gets usable now
MaxLogSize 0

# Administrator user group...
SystemGroup lpadmin


# Only listen for connections from the local machine.
port 631
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow all
BrowseLocalProtocols CUPS dnssd
BrowseAddress @LOCAL

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Web interface setting...
WebInterface Yes

# Restrict access to the server...
<Location />
Order allow,deny
Allow all
Order allow,deny
Allow all
</Location>

# Restrict access to the admin pages...
<Location /admin>
Order allow,deny
Allow all
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
AuthType Default
Require user @SYSTEM
Order allow,deny
</Location>

# Set the default printer/job policies...
<Policy default>
# Job/subscription privacy...
JobPrivateAccess default
JobPrivateValues default
SubscriptionPrivateAccess default
SubscriptionPrivateValues default

# Job-related operations must be done by the owner or an administrator...
<Limit Create-Job Print-Job Print-URI Validate-Job>
Order deny,allow
</Limit>

<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notif$
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

# All administration operations require an administrator to authenticate...
<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
AuthType Default
Require user @SYSTEM
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>

# All printer operations require a printer operator to authenticate...
<Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Pr$
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>

# Only the owner or an administrator can cancel or authenticate a job...
<Limit Cancel-Job CUPS-Authenticate-Job>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

<Limit All>
Order deny,allow
</Limit>
</Policy>

# Set the authenticated printer/job policies...
<Policy authenticated>
# Job/subscription privacy...
JobPrivateAccess default
JobPrivateValues default
SubscriptionPrivateAccess default
SubscriptionPrivateValues default

# Job-related operations must be done by the owner or an administrator...
<Limit Create-Job Print-Job Print-URI Validate-Job>
AuthType Default
Order deny,allow
</Limit>

<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notif$
AuthType Default
<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notif$
AuthType Default
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

# All administration operations require an administrator to authenticate...
<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>

# All printer operations require a printer operator to authenticate...
<Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Pr$
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>

# Only the owner or an administrator can cancel or authenticate a job...
<Limit Cancel-Job CUPS-Authenticate-Job>
AuthType Default
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

<Limit All>
Order deny,allow
</Limit>
</Policy>

#
#


Et j'ai déjà bien fait les commandes que tu m' a montré sur le lien.

Merci
Donnez votre avis
Utile
+0
plus moins
Ok essayons-en un autre, as-tu testé avec ceci ?
http://stephane.boireau.free.fr/informatique/quotas_cups/quotas_cups.html
kaireh- 20 avril 2017 à 10:57
exactement j'avais testé on utlisant ce lien que tu viens de me lancer
Lorsque j'utilise la commande

lpadmin -p HP LaserJet P2055dn \
-o job-quota-limit=50 \
-o job-quota-period=604800
-u allow:samod

Le printers.conf prend bien en compte la modif mais malgré un redémarrage de cups les utilisateurs peuvent toujours imprimer autant qu'ils le veulent.

Par contre, si j'interdis tel ou tel utilisateur sur cette imprimante, c'est bien pris en compte. Il n'y a que les quotas qui ne passent pas.

merci,
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

- Si on regarde
man lpadmin
:

       -o job-page-limit=valeur
Définir le nombre maximal de pages disponibles par utilisateur. La valeur est un nombre entier de pages pouvant être imprimées. Les pages recto verso comptent pour deux
pages.

-o job-quota-period=valeur
Définir le temps maximal disponible par utilisateur. La valeur est un nombre entier de secondes. Une journée contient 86 400 secondes.


... ces deux options sont sur une base utilisateur, donc semble nécessiter l'option
-u
.

- L'option
-u
permet de passer une liste d'utilisateur. As-tu essayé ?
- As-tu essayé avec
-u allow:all
?

Bonne chance
kaireh- 23 avril 2017 à 18:14
bonjour,
je vous remercie d'abord de votre chaleureux collaboration avec moi.
ensuite j'ai utilisé cette commande

lpadmin -p crisa -o job-quota-period=1200 -o job-page-limit=1 -o job-k-limit=1024
-u allow:all

sachant que crisa(nom de l'imprimante qui est HP LaserJet P2055dn).
comme je vous ai expliqué précédemment Le printers.conf prend bien en compte la modif mais malgré un redémarrage de cups les utilisateurs peuvent toujours imprimer autant qu'ils le veulent.

Par contre, si j'interdis ou bien j'autorise un tel utilisateur sur cette imprimante, c'est bien pris en compte. mais Il n'y a que les quotas qui ne s'applique pas en utilisant la commande suivante:
lpadmin -p crisa -o job-quota-period=1200 -o job-page-limit=1 -o job-k-limit=1024 -u allow:samod pour autorisé ou bien
lpadmin -p crisa -o job-quota-période=1200 -o job-page-limit=1 -o job-k-limit=1024 -u deny:samod pour interdire

lorsque j’édite le fichier printer.conf je vois bien les modifications qui sont prise en compte mais pourtant le quotas ne s'applique pas.
c'est le seul souci qui m’embête et que je n'arrive pas a trouver la solution.

j'espère trouver la solution avec vous

merci
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

J'ai trouvé sur cette page quelques exemples, dont certains sont dits fonctionnels :
https://community.kde.org/Printing/CUPS/Quotas#Setting_up_Quotas_for_certain_printers

En particulier :

lpadmin -p danka_infotec -o job-quota-period=604800 -o job-page-limit=100 


On voit notamment si on compare avec les exemples qui ne marchent pas que
job-quota-period=604800
semble requis. Par contre, contrairement à ce qui a été dit plutôt,
-u
ne semble pas nécessaire.

Peux-tu tester ?

Bonne chance
kaireh- 26 avril 2017 à 18:29
bonjour,
j'ai bien testé encore ce dernier exemple "lpadmin -p crisa -o job-quota-period=86400 -o job-page-limit=3, mais çà ne marche pas .
je sais pas si je fait d'autre erreur.

merci de votre colaboration
Répondre
Donnez votre avis
Utile
+0
plus moins
Hum je commence à être à court d'idées :-) Essaye de voir s'il n'est pas possible de définir des quota directement via l'interface web de cups.
http://localhost:631/

Plus précisément : dans administration > server > advanced il semblerait que tu puisses définir des quotas.

Bonne chance
kaireh- 27 avril 2017 à 14:38
bonjour,
en fait moi j'ai la version 1.5.3 pour le cups.
dans l'interfaces web du cups,dans administration >paramettre serveur>avancé.
et là dans partager les imprimantes connecté à ce systeme, je vois l'option "nombres maximum de clients" je vois pas une option qui me permet de definir les quotas.

est ce que cette option" nombre maximum de clients" me permet de difinir les quotas???

merci,
Répondre
mamiemando 27725Messages postés jeudi 12 mai 2005Date d'inscription ModérateurStatut 20 mai 2017 Dernière intervention - 2 mai 2017 à 08:22
Personnellement j'ai cups 2.2.1, et je suspecte que tes soucis liés à cups soient liés au fait que ce soit une vieille version.
Répondre
kaireh- 7 mai 2017 à 07:23
Bonjour,

D'accord je vais essayer.
J'aimerais savoir si ca marche le quotas marche pour vous avec cette version?

Merci de votre collaboration
Répondre
kaireh- 8 mai 2017 à 09:28
Bonjour,

Prière de m'envoyer le tutoriel que vous avez utilisé pour installer cette version de cups 2.2.1.Car j'ai essayé d'installer manuellement en utilisant
make install
...
Mais j'ai des erreurs et je n'arrive pas à l'installer correctement.

Voici les erreurs :

make: Warning: File `Makefile' has modification time 3,2e+08 s in the future Making all in cups... make[1]: *** No rule to make target `all'.  Stop. make: *** [install-data] Error 2


Merci
Répondre
mamiemando 27725Messages postés jeudi 12 mai 2005Date d'inscription ModérateurStatut 20 mai 2017 Dernière intervention - 9 mai 2017 à 12:14
Bonjour,

priere de m'envoyer le tuto que vous avez utilisé pour installer cette version de cups 2.2.1.car j'ai essayé d'installer manuellement en utilisant le make install.......

1) Première remarque, pourquoi ne pas mettre à jour le paquet cups plutôt que de le compiler ?

sudo apt-get update
sudo apt-get upgrade


Ce serait beaucoup plus simple.

2) Quelle version d'ubuntu utilises-tu ?

cat /etc/lsb-release


Si tu es en xenial ou plus, une simple mise à jour devrait suffire à installer une version récente de cups :
http://packages.ubuntu.com/xenial/cups

3) Pour le tutoriel c'est une installation par paquets, donc via
apt-get
ou ta logithèque comme indiqué dans la documentation.
https://doc.ubuntu-fr.org/cups
https://doc.ubuntu-fr.org/software-center

sudo apt-get install cups cups-client


Voici les erreurs :

make: Warning: File `Makefile' has modification time 3,2e+08 s in the future Making all in cups... make[1]: *** No rule to make target `all'. Stop. make: *** [install-data] Error 2 


Ces erreurs ne sont à traitrer que si tu décides d'installer cups en le compilant plutôt que de passer par les paquets. Personnellement je te recommande vivement l'installation par paquets.

Si tu tiens vraiment à compiler cups, il faut d'abord se placer dans le répertoire dans lequel tu as décompressé l'archive puis lancer
./configure
. Il faut traiter toutes les erreurs retournées par celui-ci pour que la compilation puisse arriver à terme. C'est donc plutôt cette commande qui peut te bloquer (car il n'est pas toujours évident quand on ne connait pas de savoir quels paquets installer pour résoudre ces erreurs) et qu'il faudrait me reporter.

Si cette commande finit avec succès,
make && sudo make install
devrait alors fonctionner correctement.

j'aimerais savoir si les quotas marchent pour vous avec cette version?

Je n'ai pas testé et pas le temps dans l'immédiat de tester. Et disons que peu importe le résultat, car a priori il vaut mieux utiliser la dernière version, pour ensuite faire une éventuelle remontée de bug si le problème persiste :
https://launchpad.net/ubuntu

Bonne chance
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !