Signaler

Message d'erreur de sendmail cf [Résolu]

Posez votre question indienne11 22Messages postés jeudi 29 mai 2014Date d'inscription 16 avril 2017 Dernière intervention - Dernière réponse le 16 avril 2017 à 15:27 par zipe31
Bonjour, Je suis sous ububntu 16.04 depuis trés peu de temps et ma fonction mail() est désactivée et il m'est impossible de la réactiver ..Mon serveur est Xampp non sécurisé parce que il ne me sert qu'en local pour tester la fonction mail( ) fonctionne parfaitement avec tous les autres ordinateurs sous xubuntu ou W7 mais pas avec deux acer formatés sous ubuntu un 14.04 et un autre 16.04 Ce n'est donc pas le serveur smtp qui bloque les mails ( envoyés sur notre propre boite mail ) ...
un message lors des essais de configuration de sendmail renvoient ce message difficilement compréhensible :

"WARNING: local host name (moi-Aspire-V5-531G) is not qualified; see cf/README: WHO AM I? "
Je comprends très mal l'Anglais mais je ne vois pas pourquoi je ne serais pas autorisée a utiliser le fonction mail() de php5 ..?Avec ça ce n'est pas la première fois que je crée un serveur mail sous sendmail et je commence a avoir des doutes sur le bon fonctionnement des nouveaux ubuntu que nous avions déjà abandonnés pour diverses raisons ...
Quelqu'un pourrait il me traduire ce message afin que je sois sure de l'avoir bien compris et si possible me dire ce qui se passe ...
Merci d'avance



Afficher la suite 
Utile
+0
plus moins
Salut,

Tu dois définir un nom de domaine dans /etc/hostname soit en éditant le fichier à la main soit en passant par la commande
hostnamectl
.
sudo hostnamectl set-hostname ton_domaine.com


indienne11 22Messages postés jeudi 29 mai 2014Date d'inscription 16 avril 2017 Dernière intervention - 14 avril 2017 à 12:26
Bonjour et bien c'est fait et Php.ini bien configuré pour sendmail-t-i
Répondre
zipe31 34762Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 23 juillet 2017 Dernière intervention - 14 avril 2017 à 12:57
Et ???

Parce qu'apparemment il manque la fin de ta phrase ;-(
Répondre
Donnez votre avis
Utile
+0
plus moins
La fin de quelle Phrase .? Si tu parles du message d'erreur il est complet il n'y a rien d'autre d'ajouté ..Avec ça avant il n'y avait que php.ini à paramétrer pour sendmail le " smtp localhost " ne se parametrait que sous windows que nous n’utilisons pas pour développer ..
zipe31 34762Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 23 juillet 2017 Dernière intervention - 14 avril 2017 à 16:09
La fin de quelle Phrase .?
Celle-ci :
Bonjour et bien c'est fait et Php.ini bien configuré pour sendmail-t-i
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour et bien comme je fais toujours et normalement ça marche sans aucun problèmes :

"sendmail_path = /usr/sbin/sendmail -t -i"
zipe31 34762Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 23 juillet 2017 Dernière intervention - 15 avril 2017 à 08:20
Ok. Donc tu as bien défini un nom de domaine dans /etc/hostname ?
Et ça marche toujours pas ? Toujours le même message d'erreur ?

Peut-être faut-il aussi reconfigurer le fichier /etc/hosts pour qu'il soit en harmonie avec le domaine, à savoir rajouter l'extension ton_domaine.com à la fin des hôtes.
Répondre
Donnez votre avis
Utile
+0
plus moins
Hier soir j'ai eu un mail d'un de mes correspondant d'Amérique Latine qui me dit avoir eu les mêmes problèmes avec ubuntu 14.04 il a tout effacé sendmail et Xampp et ensuite fait un update et un upgrade suivis d'un autoremove et d'un autoclean pour être sur que tous soit bien effacé et surtout il a réinstallé sendmail avant xampp et ça a fonctionné du premier coup après paramétrage de php.ini
Ce WE j'ai un peu plus le temps de m'amuser je vais essayer ça et je vous tient au courant
zipe31 34762Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 23 juillet 2017 Dernière intervention - 15 avril 2017 à 09:55
Ben… bon week-end alors ;-)
Répondre
Donnez votre avis
Utile
+0
plus moins
Merci bon WE de Pâques a tous ..Effectivement j'ai suivi les conseils de mon collègue et tout a fonctionné a merveille même sans paramétrer php.ini je pense qu'il faut installer sendmail avant Xampp ..pourquoi ? Mystère
Merci pour les réponses je mets en résolu
zipe31 34762Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 23 juillet 2017 Dernière intervention - 16 avril 2017 à 15:27
Merci du retour et bonne continuation.
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !