Signaler

Probleme fonction SI() [Résolu]

Posez votre question Fogiel 26Messages postés dimanche 12 mai 2013Date d'inscription 13 avril 2017 Dernière intervention - Dernière réponse le 13 avril 2017 à 14:21 par Fogiel
Bonjour, j'ai un problème avec une fonction si, je m'explique :

ma fonction est la suivante :
• Si l'utilisateur entre un nombre entre 1 et 9 alors, afficher : 0,3
• Si l'utilisateur entre un nombre entre 10 et 19 alors, afficher : 0,5
• Si l'utilisateur entre un nombre entre 20 et 29 alors, afficher : 0,8

Jusque la tout fonctionne.

Ensuite, je souhaite prendre la cellule qui affiche la valeur 0,3 (ou 0,5 ou 0,8 selon ce que l'utilisateur entrera), puis la multiplier par un nombre, et là... #VALEUR !
J'en déduit que ma cellule 0,3 est reconnue comme du texte et non pas un nombre, non ?
Quoi qu'il en soit, je ne sais pas comment procéder :/

Savez vous comment palier a ce problème ? s'il vous plait

Cordialement
Afficher la suite 
Utile
+1
plus moins
Bonjour

formule en B1 pour une valeur de référence en A1

=SI(A1="";"";SI(A1<=9;0,3;SI(A1<=19;0,5;0,8)))



crdlmnt
SI
la cellule suivante renverra valeur si A1 est vide
pour éviter ça:
soit remplacer ;""; par ;0;
soit écrire:
=SI(N1;"";"";B1*nombre)

crdlmnt
Cette réponse vous a-t-elle aidé ?  
Fogiel 26Messages postés dimanche 12 mai 2013Date d'inscription 13 avril 2017 Dernière intervention - 12 avril 2017 à 21:14
Oula j'ai les neurones qui fument, je m'embrouille tout seul je ne comprends plus rien. Je pense qu'on n'utilise pas la même syntaxe ou alors je suis complètement nul ^^'

Moi j'ai cette ligne de calcul en E6 :

=SI(B2<=9;"0,3";SI(B2<=19;"0,5";SI(B2>19;"0,8")))

du coup je dois corriger quoi pour que je puisse utiliser la cellule E6 dans un autre calcul ? s'il vous plait

Merci beaucoup de m'avoir répondu rapidement :D
Répondre
Vaucluse 19624Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 24 mai 2017 Dernière intervention - 13 avril 2017 à 06:41
Bonjour
Tout simplement enlever les guillemets qui encadrent vos résultats. Ces guillemets pour Excel, transforment les valeurs en texte, ce qui interdit le calcul ensuite.
crdlmnt
Répondre
Fogiel 26Messages postés dimanche 12 mai 2013Date d'inscription 13 avril 2017 Dernière intervention - 13 avril 2017 à 14:21
Oh punaise 1000000000000 mercis, vraiment c'est impeccable !
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !