Signaler

Peux t on faire un Somme Decaler avec une condition [Résolu]

Posez votre question david3434 22Messages postés mercredi 26 octobre 2016Date d'inscription 13 avril 2017 Dernière intervention - Dernière réponse le 13 avril 2017 à 11:01 par david3434
Bonjour à tous,

Je souhaite automatiser mon reporting excel mais après plusieurs essais je suis totalement bloqué. J'ai mis en image mon pb car je ne vois pas comment l'expliquer autrement
Afficher la suite 
Utile
+0
plus moins
Voici la pièce jointe.
Donnez votre avis
Utile
+0
plus moins
Bonjour
Illisible, on s'arrache les yeux là
Déposez carrément la feuille Excel ici:
https://mon-partage.fr
et revenez ici coller le lien créé sur le site
à vous lire
crdlmnt
david3434 22Messages postés mercredi 26 octobre 2016Date d'inscription 13 avril 2017 Dernière intervention - 7 avril 2017 à 15:09
Bonjour,

Oui pardon cela va chercher dans un 3e onglet non disponible dans ce que j'ai envoyé, c'est bien la case A2 dans l'onglet "Mois"
Répondre
Vaucluse 19601Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 19 mai 2017 Dernière intervention - 7 avril 2017 à 17:27
et vous avez quoi exactement dans la case A2 de cette feuille?
Répondre
david3434 22Messages postés mercredi 26 octobre 2016Date d'inscription 13 avril 2017 Dernière intervention - 11 avril 2017 à 14:57
Bonjour,

Désolé pour la réponse tardive je n'avais pas vu le message. J'ai le numéro 3, qui correspond à mon mois de Mars.
En fait chaque mois je mets à jour ce chiffre et tout le reste de mon reporting se met à jour automatiquement (sauf cette dernière formule qui bloque)
Pour Avril j'y mettrai donc 4 ^^
Répondre
Vaucluse 19601Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 19 mai 2017 Dernière intervention - 11 avril 2017 à 16:44
Bonjour
alors si vous mettez le N° du mois en A2, il ne faut pas utiliser:
=SOMMEPROD(('Pertes N'!$G$2:$R$2=Mois!$A$2).....
mais
=SOMMEPROD(('Pertes N'!$G$2:$R$2=Mois!$A$2) si vous avez des N° de mois en G
et si jamais vous avez des dates en G, utilisez:
=SOMMEPROD((MOIS('Pertes N'!$G$2:$R$2=$A$2)

pour info:
quand vous écrivez = MOIS(A2) Excel prend en compte le N° du mois qui correspond au 3° jour de son calendrier, et donc au 03/01/1900
(essayez de placer la formule dans une cellule et vous verrez)
crdlmnt
Répondre
david3434 22Messages postés mercredi 26 octobre 2016Date d'inscription 13 avril 2017 Dernière intervention - 13 avril 2017 à 11:01
Bonjour,

C'est bon j'ai la solution ! le problème venait d'un N/A sur ma dernière ligne du coup la formule bloquait. Voici la formule qui fonctionne
=SOMMEPROD(('Pertes N'!$R$3:$R$8403='Retraitement pertes'!$H3)*('Pertes N'!$D$3:$O$8403)*('Pertes N'!$D$2:$O$2=Mois!$A$2))

Pour "Mois!$A$2" cela ne posait pas de problème finalement, Excel prenait bien en compte le chiffre dans la case.

En tout cas merci pour votre aide précieuse ^^
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !