Signaler

Calculer le nombre de participants [Résolu]

Posez votre question cavelavestave 55Messages postés vendredi 8 mars 2013Date d'inscription 12 juillet 2017 Dernière intervention - Dernière réponse le 13 mars 2017 à 11:42 par yclik
Bonjour à toutes et à tous !

Je souhaite calculer le nombre de participants à un cours (selon le nom du cours, non de la date), sachant que le présent document se présente comme suit :

Colonne A : nom du participant Colonne B : nom du cours Colonne C : date


Exemple :

A-----------B-------------------C
Jean--------Gestion-----------01/02/2017
Jean--------Gestion-----------02/02/2017
Jean--------Comptabilité-----01/03/2017
Jean--------Planification------10/03/2017
Marc--------Gestion-----------01/02/2017
Marc--------Comptabilité-----01/03/2017
Sophie------Gestion-----------01/02/2017
Sophie------Gestion-----------02/02/2017
Sophie------Comptabilité-----01/03/2017
Sophie------Planification------10/03/2017
Sophie------Ergonomie-------11/03/2017


Dans cette situation, je cherche une formule me permettant de donner un résultat qu'on pourrait traduire par : "Dans le cours "Gestion" il y avait 3 participants".

Si on utilisait un NB.SI, cela ne marcherait pas ici. Il faut une formule qui ne compte que les noms différents, pas l'addition des noms des participants au cours de gestion. Un NB.SI avec comme critère "Gestion" donnerait un résultat de 5 alors qu'il y a 3 personnes différentes.

Je pense simplement faire un tableau avec le nom des cours en première colonne et la colonne suivante le résultat du nombre de participants.

D'avance merci pour votre aide !

Utile
+0
plus moins
Bonjour,

Si la liste des participants va de a2 à a11,

on a
=SOMMEPROD(1/NB.SI($A2:$A11;$A$2:$A11))

C'est une formule classique a ranger dans un coin pour un possible usage futur


Crdmt
cavelavestave 55Messages postés vendredi 8 mars 2013Date d'inscription 12 juillet 2017 Dernière intervention - 13 mars 2017 à 11:28
Merci pour votre réponse, cependant cela donne le nombre total de participants, et non le nombre de participants par cours (par exemple pour gestion, comment vous-y prendriez-vous ?).
Répondre
DjiDji59430 1656Messages postés samedi 19 avril 2008Date d'inscription 24 septembre 2017 Dernière intervention - 13 mars 2017 à 11:41
Re


http://www.cjoint.com/c/GCnlpaSPTOy

Crdmt
Répondre
yclik 1129Messages postés vendredi 25 juillet 2014Date d'inscription 25 septembre 2017 Dernière intervention cavelavestave - 13 mars 2017 à 11:42
Bonjour
=SOMMEPROD(A2:A12<>"";B2:B12="Gestion")
ou
=SOMMEPROD(C2:C12>0;B2:B12="Gestion")

Voir aussi du côté des tableaux croisés dynamiques
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !