Solution excel [Résolu]

Berorn - 16 févr. 2017 à 22:52 - Dernière réponse : JvDo 1792 Messages postés mercredi 27 juillet 2005Date d'inscription 5 décembre 2017 Dernière intervention
- 17 févr. 2017 à 08:33
Bonjour,
Je voudrais savoir si c'est possible de réaliser cela :
Cellule A1 : "texte1"
Cellule A2 : "texte2"
Cellule A3 : "texte3"
Je voudrais donc afficher dans la cellule A4 : texte1/texte2/texte3.
Sauf que des fois il se peut ques des cellules soient vides : par exemple, dans l'exemple du dessus : cellule A2 est vide donc dans A4 je voudrais : texte1/texte3
Voilà si quelqu'un pouvait m'aider, je lui en serais reconnaissant.
Merci
Afficher la suite 

6 réponses

Répondre au sujet
gbinforme 14411 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 16 févr. 2017 à 23:05
+1
Utile
Bonjour,

Je te propose cette formule :
=SI(A1="";;A1)&SI(A2="";;"/"&A2)&SI(A3="";;"/"&A3)
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de gbinforme
Berorn 5 Messages postés jeudi 16 février 2017Date d'inscription 28 février 2017 Dernière intervention - 16 févr. 2017 à 23:10
0
Utile
Merci cela fonctionne
Commenter la réponse de Berorn
Berorn 5 Messages postés jeudi 16 février 2017Date d'inscription 28 février 2017 Dernière intervention - 17 févr. 2017 à 00:36
0
Utile
Est ce que tu aurais une solution pour ca :
Si A2=texte 1 alors A6=texte 3 ou A2=texte 2 alors A6=texte4 ou sinon A6=texte 5
Ex: pour 1 je veux Fr
Pour 2 je veux Al
Mais pour 3,4,5 je veux Dr
Merci
Commenter la réponse de Berorn
JvDo 1792 Messages postés mercredi 27 juillet 2005Date d'inscription 5 décembre 2017 Dernière intervention - 17 févr. 2017 à 01:23
0
Utile
2
Bonsoir,

Essaye =CHOISIR(MIN(3; A2);"Fr";"Al";"Dr")

Cordialement
Berorn 5 Messages postés jeudi 16 février 2017Date d'inscription 28 février 2017 Dernière intervention - 17 févr. 2017 à 07:37
Je me suis mal exprimer avec mon exemple ! Desole
Je joins un excel avec. Ce que je veux c'est dans la colonne D
La logique a respecter :
Si A1="FR" OU "Al" alors D1="FR"OU"Al"/"D"&B1
Si A1="Pl" alors D1="Pl"/"t"&C1
Si A1="TA" alors D1="TA"/"M"&B1
Voilà merci de vos reponses
JvDo 1792 Messages postés mercredi 27 juillet 2005Date d'inscription 5 décembre 2017 Dernière intervention > Berorn 5 Messages postés jeudi 16 février 2017Date d'inscription 28 février 2017 Dernière intervention - 17 févr. 2017 à 08:33
Effectivement, j'étais loin !

En D1 : =SI(OU(A1="FR";A1="Al");A1&"/D"&B1;SI(A1="Pl";A1&"/t"&C1;SI(A1="TA";A1&"/M"&B1;"erreur A1")))

Cordialement
Commenter la réponse de JvDo