Signaler

SOMMEPROD / Chaine de caractères [Résolu]

Posez votre question Dabazt 4Messages postés jeudi 16 février 2017Date d'inscription 17 février 2017 Dernière intervention - Dernière réponse le 17 févr. 2017 à 11:39 par Dabazt
Bonjour à tous,

j'ai besoin de votre aide sur une formule que je n'arrive pas à trouver...

J'ai dans une colonne A des Fruits (Pomme / Poire / Banane etc...)
Dans la colonne B des codifications, représentées par des chaines de 4 chiffres exemple : 2100, 2112, 0121

J'aimerais réaliser une formule qui permette de donner le nombre de banane ayant comme 1er chiffre de codification un "2", pareil pour le 2ème chiffre, le 3ème, le 4ème...

Exemple
=SOMMEPROD(A2:A10="Banane")*(codifications ayant en 3ème caractère un "2")

En vous remerciant d'avance !
Dabazt
Afficher la suite 
Utile
+1
plus moins
Bonjour
1° caractère
=SOMMEPROD((A2:A10="banane)*(GAUCHE(B2:B10;1)*1=2))
2° caractère
=SOMMEPROD((A2:A10="banane)*(STXT(A2:A10;2;1)*1=2))
3° caractère
=SOMMEPROD((A2:A10="banane)*(STXT(A2:A10;3;1)*1=2))
4° caractère
=SOMMEPROD((A2:A10="banane)*(DROITE(B2:B10;1)*1=2))

crdlmnt
Cette réponse vous a-t-elle aidé ?  
Dabazt 4Messages postés jeudi 16 février 2017Date d'inscription 17 février 2017 Dernière intervention - 16 févr. 2017 à 17:37
Bonsoir,

merci beaucoup, ça fonctionne parfaitement !

Très bonne fin de journée,

Dabazt
Répondre
Dabazt 4Messages postés jeudi 16 février 2017Date d'inscription 17 février 2017 Dernière intervention - 17 févr. 2017 à 10:20
En fait, il y a un petit problème !!

La formule pour 2ème et 3ème caractère ne fonctionne pas dans mon fichier car il y a des cases vides.
Cela me renvoie VALEUR.
Quand je remplis avec des fausses codifications, cela remarche.
Comment faire pou ignorer les cases vides ?
Répondre
Vaucluse 19619Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 23 mai 2017 Dernière intervention - 17 févr. 2017 à 10:36
Bonjour
si vous avez des "bananes" en A qui n'ont pas de code en B, essayez de ne pas passer par une valeur cherchée numérique afin de ne pas utiliser le*1
soit à faire suivre dans tous les codes
=SOMMEPROD((A2:A10="banane)*(GAUCHE(B2:B10;1)="2"))
(placez bien le 2 entre guillemets)
et si ça ne va pas revenez, on posera une condition sur le calcul
crdlmnt
Répondre
Dabazt 4Messages postés jeudi 16 février 2017Date d'inscription 17 février 2017 Dernière intervention - 17 févr. 2017 à 11:39
Merci beaucoup Vaucluse, tout fonctionne !

Bonne journée,

Dabazt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !