Signaler

Service VNC ne démarre pas [Résolu]

Posez votre question addu37 88Messages postés vendredi 21 août 2015Date d'inscription 18 février 2017 Dernière intervention - Dernière réponse le 16 févr. 2017 à 16:11 par addu37
Bonjour,

J'ai reçu aujourd'hui mon raspberry PI 3. J'ai installé raspbian, l'ai mis à jour et ai installé tightvnc.

Quand je le démarre tout vat bien mais quand j'ai créé un script pour qu'il se lance au démarrage il me met
failed to start VNC.service
.

Merci de votre aide.
Afficher la suite 
Utile
+0
moins plus
Bonjour,

Copie colle nous le message d'erreur exact ainsi que le contenu du script en question.

Normalement si tu as bien fait les choses, tu as créé un script dans
/etc/init.d
(e.g.
/etc/init.d/tightvnc
) structuré un peu dans cet esprit (en adaptant les commandes déclenchées dans le bloc "case") :
http://www.commentcamarche.net/forum/affich-25769449-minecraft-serveur#1

Une fois créé, tu pourras typiquement lancer en root :

service tightvnc stop
service tightvnc start
service tightvnc restart


Une autre approche, très sale, consiste à ajouter une commande dans
/etc/rc.local
(éventuellement un appel à un script). Mais ce n'est vraiment pas ce que je recommande.
http://www.commentcamarche.net/forum/affich-30902545-script-au-demarrage-qui-lance-un-autre-script#1

Bonne chance
addu37 88Messages postés vendredi 21 août 2015Date d'inscription 18 février 2017 Dernière intervention - 16 févr. 2017 à 10:32
Bonjour, merci m'avoir répondu. J'ai bien mis le script dans /etc/init.d/ sous le nom VNC.

https://image.noelshack.com/fichiers/2017/07/1487237495-img-20170216-102553.jpg

Mais c'est au démarrage qu'il ne veut pas se lancer sinon quand je fais la commande tightvnc start tout vat bien.

PS : le message d'erreur
https://image.noelshack.com/fichiers/2017/07/1487237503-img-20170216-101350.jpg
Répondre
Donnez votre avis
Utile
+0
moins plus
Salut,

Sur le Raspberry Pi 3 avec Raspbian, un serveur VNC est installé nativement, il suffit juste de l'activer via le menu ou depuis
raspi-config
:

https://www.raspberrypi.org/documentation/remote-access/vnc/
Donnez votre avis
Utile
+0
moins plus
C'est bon j'ai trouvé quand j'ai enregistré le script avec nano j'avais un mauvais nom. Désolé de vous avoir dérangé pour une petite erreur et merci de vos réponses.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !