Signaler

Problème de syntaxe fonction SI [Résolu]

Posez votre question olis8319 52Messages postés samedi 21 janvier 2017Date d'inscription 17 mai 2017 Dernière intervention - Dernière réponse le 16 févr. 2017 à 16:32 par Mazzaropi
Bonjour,
j'ai un classeur avec entre autre 1 feuille (Info+Engagés) et 1 feuille (résultats)

Dans la feuille (Résultats) j'ai mis en cellule D11 la fonction =SI(ESTVIDE('Info+Engagés'!A12;'Info+Engagés'!H2);"";RANG(D10;$D$10:$D$49))

cette fonction doit me permettre soit ne rien afficher si les cellules (Info+Engagés A12 et H2) sont vide toutes les deux ou afficher en D11 un RANG par rapport a la valeur de D10

Problème il y a un argument de trop dans ma fonction quelqu'un aurait il une idée a me suggérer ?

Afficher la suite 
Utile
+0
plus moins
Bonjour La fonction ESTVIDE n'attend qu'une seule valeur...
Tu peux faire un ET dans ton SI
un truc du genre

=SI(ET(ESTVIDE('Info+Engagés'!A12);ESTVIDE('Info+Engagés'!H2));"";RANG(D10;$D$10:$D$49))

Donnez votre avis
Utile
+0
plus moins
Merci jordan45 j'ai corrigé ma formule comme ceci:

=SI(OU(ESTVIDE('Info+Engagés'!A12);ESTVIDE('Info+Engagés'!H2));"";('Cav1'!D38))

et cela fonctionne parfaitement
Donnez votre avis
Utile
+0
plus moins
olis8319, Bonjour.

Vérifiez que, maintenant, la formule fonctionne.

=SI( OU(ESTVIDE('Info+Engagés'!A12);ESTVIDE('Info+Engagés'!H2)); ""; 'Cav1'!D38)

J'espère avoir aidé.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !