Fonction age [Résolu]

eltharion76 - 15 févr. 2017 à 09:36 - Dernière réponse : gbinforme 14419 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention
- 15 févr. 2017 à 09:40
Bonjour,

je cherche à créer un fonction pour créer des catégories d'age (-60ans, 60-75ans etc)
j'ai essayé :
=SI(C2<60;"-60ans";SI(C2<65;"60-65ans";SI(C2<70;"65-70ans";SI(<75;"70-75ans";"+75"))))
merci d'avance

Afficher la suite 

2 réponses

Répondre au sujet
Vaucluse 20852 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - 15 févr. 2017 à 09:40
0
Utile
Bonjour
et si vous nous disiez ce qui ne fonctionne pas dans votre formule, qui est correcte?
... sauf peut être de rajouter une condition =SI(C2="";""; si C2 est vide pour éviter d'afficher -60
à vous lire
crdlmnt
Commenter la réponse de Vaucluse
gbinforme 14419 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - Modifié par gbinforme le 15/02/2017 à 10:13
0
Utile
Bonjour,

Il te manque 1 C2
=SI(C2<60;"-60ans";SI(C2<65;"60-65ans";SI(C2<70;"65-70ans";SI(C2<75;"70-75ans";"+75"))))

Tu peux aussi utiliser une formule plus facilement modifiable :
=CHOISIR(EQUIV(C2;{0;60;65;70;75};1);"-60ans";"60-65ans";"65-70ans";"70-75ans";"+75")

Toujours zen
La perfection est atteinte, non pas lorsqu'il n'y a plus rien à ajouter, mais lorsqu'il n'y a plus rien à retirer.  Antoine de Saint-Exupéry
Commenter la réponse de gbinforme