Signaler

Décaler une formule indirect [Résolu]

Posez votre question Jonatan84 5Messages postés mardi 23 août 2016Date d'inscription 20 février 2017 Dernière intervention - Dernière réponse le 16 févr. 2017 à 06:53 par Vaucluse
Bonjour,

je me doute que j'ai une vieille question, mais ça fait plus de 2 heures que je tente de trouver.

C'est assez simple.
J'ai plusieurs formules qui réfère à un mot qui est cherché dans une autre feuille.

J'utilise "indirect" et ça marche très bien.

Ex: =NB.SI.ENS(Natation!$K$6:$K$10486;"oui";Natation!$H$6:$H$10486;INDIRECT("A20"))+NB.SI.ENS(Natation!$K$6:$K$10486;"";Natation!$H$6:$H$10486;INDIRECT("A20"))

J'ai une liste de 150 noms environ... indirect va de A20 à A150

Je me suis rendu compte à ma grande tristesse que lorsque je glisse la formule d'une ligne à l'autre, les numéros de ligne change.. je descends + 1 +1... MAIS INDIRECT ne change pas lui, c'est toujours la même référence... j'ai fait une fois la correction manuel... j'ai changé les chiffres 1 à 1... C'EST LONG

Je me doute qu'il y a un possibilité avec la fonction adresse de faire un +1 à indirect...

J'ai tout tenté mais ça ne marche pas...

MERCI!!!!
Afficher la suite 
Utile
+0
plus moins
Il faudrait qu'on voie ton fichier.
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (8192 Ko maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Jonatan84 5Messages postés mardi 23 août 2016Date d'inscription 20 février 2017 Dernière intervention - 15 févr. 2017 à 22:06
Merci pour votre réponse, mais je n'aurais pas pu vous télécharger le fichier, car il contient beaucoup d'information confidentielle...
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour
vous n'avez peut être pas tout tenté :-))
essayez dans le code indirect

=INDIRECT("A"&LIGNE(A20))

crdlmnt
Jonatan84 5Messages postés mardi 23 août 2016Date d'inscription 20 février 2017 Dernière intervention - 15 févr. 2017 à 22:05
Merci ça fonctionne très bien. Je me doutais que c'étais très simple, mais étrangement je ne maitrise pas le &
Répondre
Vaucluse 19619Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 23 mai 2017 Dernière intervention - 16 févr. 2017 à 06:53
Bonjour
le & équivaut au code CONCATENER
soit "A"&LIGNE(20) qui peut aussi s'écrire
CONCATENER("A";LIGNE(A20))
Je passe le sujet en résolu
Bonne route
crdlmnt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !