Signaler

Rechercher Valeur dans une colonne selon deux critères [Résolu]

Posez votre question Sormick 75Messages postés dimanche 10 novembre 2013Date d'inscription 14 février 2017 Dernière intervention - Dernière réponse le 14 févr. 2017 à 20:40 par Mike-31
Bonjour,

J'ai un peu de mal à expliquer ce que je recherche.
Je vous envoie une photo de mon tableau. Je pense vous comprendrez mieux.

Cordialement,
Afficher la suite 
Utile
+0
moins plus
Bonsoir,

il aurait été préférable d'avoir un bout de fichier qu'une capture écran, mais regarde comme cela

=SOMMEPROD(($A$2:$A$20=$L$1)*($B$2:$B$20=$M$1)*($C$2:$C$20))

si tu n'as qu'une formule tu peux travailler en relatif
=SOMMEPROD((A2:A20=L1)*(B2:B20=M1)*(C2:C20))

ou avec des plages nommées
=SOMMEPROD((Dat=L1)*(Nom=M1)*(Text))

tu peux également utiliser cette formule matricielle qu'il faudra confirmer en cliquant en même temps sur les trois touches Ctrl, Shift et Entrée et si tu fais bien la formule se placera entre ce type d'accolade {}
=INDEX(C2:C12;EQUIV(L1&M1;A2:A12&B2:B12;0))

A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Sormick 75Messages postés dimanche 10 novembre 2013Date d'inscription 14 février 2017 Dernière intervention - 14 févr. 2017 à 20:25
Malheureusement j'ai une erreur #valeur! sur votre formule SOMMEPROD
Voici le tableau ci-joint:
http://www.cjoint.com/c/GBos1dAarKc
Répondre
Donnez votre avis
Utile
+0
moins plus
Re,

utilise cette formule matricielle qu'il faudra confirmer en cliquant en même temps sur les trois touches Ctrl, Shift et Entrée et si tu fais bien la formule se placera entre ce type d'accolade {}
=INDEX(C2:C12;EQUIV(L1&M1;A2:A12&B2:B12;0))
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !