Signaler

SOMME PROD avec deux conditions [Résolu]

Posez votre question Blandine444 9Messages postés mardi 14 février 2017Date d'inscription 16 février 2017 Dernière intervention - Dernière réponse le 16 févr. 2017 à 17:40 par Blandine444
Bonjour à tous,

Je cherche à réaliser une formule mais je ne m'en sors pas, j'espère que vous pourrez m'apporter votre précieuse aide.

Je souhaite additionner le nombre de fois ou la valeur "7,75" et "4" apparaissent dans mes colonnes de relevé d'heures.
- 7,75 = 1
- 4 = 0,5

J'ai réussi à réaliser une formule mais qui n'additionne pas..
=SOMMEPROD(SI(C5:C13=7,75;1;SI(C5:C13=4;0,5;"")))

Je vous remercie par avance pour vos retours,
Bonne fin de journée,
Blandine.
Afficher la suite 
Utile
+0
moins plus
Bonjour

Essayer cette formule

=SOMMEPROD(($C$5:$C$13=7,75)*($C$5:$C$13)/7,75)+SOMMEPROD(($C$5:$C$13=4)*($C$5:$C$13)/8)

OU

=SOMMEPROD((($C$5:$C$13=7,75)*($C$5:$C$13)/7,75)+(($C$5:$C$13=4)*($C$5:$C$13)/8))

Donnez votre avis
Utile
+0
moins plus
Bonsoir

SOMMEPROD n'est peut pas utile ici:

=NB.SI(C5:C13;7,75)+NB.SI(C3:C15;4)/2


ou alors si vous tenez à SOMMEPROD:

=SOMMEPROD(((C5:C13=7,75)+(C5:C13=4)/2)*1)

crdlmnt

Donnez votre avis
Utile
+0
moins plus
Super , merci beaucoup à vous deux ( Vaucluse et Philou10120 ) , toutes vos formules fonctionnent à la perfection ,

Par contre si cela ne vous embête pas , est-il possible que vous me décortiquiez vos formules ou au moins une afin que je puisse comprendre comment vous les avez construites ?

Merci encore ,
Blandine
Donnez votre avis
Utile
+0
moins plus
Bonjour Blandine444

=SOMMEPROD((($C$5:$C$13=7,75)*($C$5:$C$13)/7,75)+(($C$5:$C$13=4)*($C$5:$C$13)/8))

($C$5:$C$13=7,75) regarde combien de données réponde au critère 7.75
$C$5:$C$13)fait la somme des critères correspondant
/7.75 divise la somme pour obtenir la quantité
+
($C$5:$C$13=4) regarde combien de données réponde au critère 4
$C$5:$C$13)fait la somme des critères correspondant
/8 divise la somme par 4x2 (la valeur étant 0.5) pour obtenir la quantité
Donnez votre avis
Utile
+0
moins plus
Bonjour
à mon tour (salut Philou)
=SOMMEPROD(((C5:C13=7,75)+(C5:C13=4)/2)*1)
complet le nombre de cellule avec 7,75
compte le nombre de cellules avec 4 et le divise par deux (puisque 0,5=1/2
fait le total de l'ensemble

NB.SI fait la même chose en deux fois.

crdlmnt
PHILOU10120 4247Messages postés lundi 16 avril 2012Date d'inscription 24 février 2017 Dernière intervention - 15 févr. 2017 à 10:23
Bonjour Vaucluse

Je vois que l'on peut simplifier la formule,
Comme c'est vous qui m'aviez expliqué le fonctionnement de la fonction SOMMEPROD
il y a un moment !
Vous venez de me montrez que l'on peut faire encore plus simple
Merci Vaucluse c'est super !
Répondre
Donnez votre avis
Utile
+0
moins plus
Bonjour VAUCLUSE et PHILOU10120,

un grand MERCI à vous deux pour ces explications, je comprends mieux à présent la construction des formules,

Merci encore,
Très Bonne journée à vous ,
Blandine444
Blandine444 9Messages postés mardi 14 février 2017Date d'inscription 16 février 2017 Dernière intervention - 16 févr. 2017 à 17:08
Bonjour à tous,

Je ne sais pas si je dois créer un nouveau sujet ou si je peux poser ma question sur celui-ci étant donné que ma question est dans la continuité de la formule .
Dans le doute je me permets de la poser ici, je supprimerai mon post pour créer un nouveau sujet si cela est gênant.

Ma formule se complique un peu après avoir montrée le fichier à ma collègue.

Pour reprendre le post de base :

Je souhaitais additionner le nombre de fois ou la valeur "7,75" et "4" apparaissent dans mes colonnes de relevé d'heures.
- 7,75 = 1
- 4 = 0,5

ce qui a donné choix à plusieurs formules dont celle ci :

=NB.SI(C5:C13;7,75)+NB.SI(C3:C15;4)/2

Ma collègue me demande s'il est possible de modifier la formule afin que :

- Si >= 7,75 = 1
- Si > 4 = 1 et si < 4 = 0,5

Je vous remercie par avance pour votre aide,
Blandine444
Répondre
Donnez votre avis
Utile
+0
moins plus
Bonjour Blandine444

Essayer ceci

=SOMMEPROD(((C5:C13>4)+(C5:C13=4)/2)*1)
Blandine444 9Messages postés mardi 14 février 2017Date d'inscription 16 février 2017 Dernière intervention - 16 févr. 2017 à 17:40
Bonjour Philou10120,

Vous êtes super, ça marche à la perfection !
Merci beaucoup !!!

Bonne fin de journée,
Blandine444
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !