Signaler

Enlever la ligne en cours pour une recherche V [Résolu]

Posez votre question guerando 146Messages postés mercredi 31 mars 2010Date d'inscription 14 septembre 2017 Dernière intervention - Dernière réponse le 13 févr. 2017 à 14:15 par Vaucluse
Bonjour à tous,

je suis entrain de faire un petit fichier ,
http://www.cjoint.com/c/GBnmtZCSrmZ

je but etant de saisir le numéro de fax de client, et dés grâce à la recherche V si je renote un numéro de fax déjà noté la formule me prévient. J'ai tapé le premier numéro "5" comme c'est le seul il ne devrait pas me dire que c'est déjà noté, mais c'est comme un miroir (je ne suis pas sur d'etre claire... lol ) il trouve bien entendu le 5 qui vient d'être saisi. j'aurai aimé lui dire de faire la recherche V en enlevant la ligne sur lequel on est.

avez vous une idée ?

merci d'avance de votre aide

Utile
+0
plus moins
Bonjour,

En délimitant la tableau de recherchev() à la ligne précédente
Exemple : tu travaille sur la ligne 5 et tu entres
RECHERCHEV(A5;$A$1:$A4;2;FAUX)

Les $ sont là pour empêcher que les colonnes et les numéros de ligne ne changent quand tu fais glisser la formule. C'est exprès que le dernier numéro de ligne n'en a pas.
Si tu as déjà d'autres numéros pouvant être renseignés en-dessous de ta ligne, il faut employer un deuxième recherchev(), en reprenant mon exemple : RECHERCHEV(A5;$A6:$A$9999;2;FAUX).
Donnez votre avis
Utile
+0
plus moins
Bonjour

on ne voit pas très bien, dans votre modèle, à quoi va servir l'option "nouveau". Il faudrait pour ça avoir une liste des noms clients déjà entrés pour pouvoir déterminer si c'est nouveau ou pas!

par contre, sans même la colonne contrôle, vous pouvez afficher en A le statut fait ou déjà fait avec cette formule à tirer sur la hauteur utile à partir de A5

=SI(B5="";"";SI(NB.SI($B$4:B4;B5)=1;"déjà fait";SI(B5<>"";"fait"))
attention au $ aux bons endroits

(il est même possible de mettre une alerte qui passe la cellule en rouge si vous placez un doublon, ce qui éviterait même la colonne A
Revenez si besoin

crdlmnt
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !