Signaler

[PHP] problème fonction mail() et href="" [Résolu]

Posez votre question jiantox 1060Messages postés mardi 30 septembre 2008Date d'inscription 10 février 2017 Dernière intervention - Dernière réponse le 10 févr. 2017 à 19:33 par jiantox
Bonjour,

je rencontre aujourd'hui un bug (enfin je crois) très étrange.
J'utilise un formulaire tout simple (textarea, submit) pour un système de newsletter.
Le problème est le suivant :

quand j'entre ceci :
<a href="https://domaine.fr/dossier/" rel="nofollow noopener noreferrer" target="_blank" style="font-size:30px;color:#3ab6e4;font-weight:bold;">texte du lien</a>

le mail n'abouti jamais. En revanche avec ceci :
<a style="font-size:30px;color:#3ab6e4;font-weight:bold;" >texte du lien</a>

le mail arrive bien.

Je précise que j'ai d'autres liens dans le message qui eux passent. J'ai essayé de virer le style et laisser le href mais ça ne fonctionne que quand j'enlève le href

Une idée d'où ça pourrais venir ?

Merci d'avance

EDIT : c'est CCM qui rajoute rel="nofollow noopener noreferrer" target="_blank" ? je n'ai pas copié/collé ça :/
Afficher la suite 
Utile
+0
plus moins
Le bug devait venir côté serveur, je viens d'essayé de nouveau et ça a fonctionné.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !