Somme affiche un ZERO en négatif [Résolu]

SHAPE_OF_DESPAIR 7 Messages postés mercredi 8 février 2017Date d'inscription 16 février 2017 Dernière intervention - 9 févr. 2017 à 07:50 - Dernière réponse : SHAPE_OF_DESPAIR 7 Messages postés mercredi 8 février 2017Date d'inscription 16 février 2017 Dernière intervention
- 9 févr. 2017 à 14:53
Bonjour,
problème tout simple, la somme d'une colonne (balance horaire) me donne zéro.
Sauf que cela m'affiche un zéro négatif et que je n'arrive pas afficher un simple 0.
Ça impacte mon tableau car j'ai des Mises en forme conditionnelles :
Vert pour une somme positive. Rouge pour une somme négative. Rien en cas de 0.
Et là, ça m'affiche ce fichu -0:00:00 en rouge.
Je ne trouve pas la solution !
J'ai bien essayé de changer les paramètres des MFC (supérieur ou inférieur à 0), mais avec le format [h]:mm:ss, ça ne joue pas. Le zéro négatif s'affiche toujours en rouge.
Merci à vous.
Afficher la suite 

6 réponses

Répondre au sujet
Vaucluse 20872 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - 9 févr. 2017 à 08:03
0
Utile
1
Bonjour
comment est obtenu le résultat dans la cellule, une formule?
et que vous affiche la cellule en format nombre / standard?
à vous lire
crdlmnt
SHAPE_OF_DESPAIR 7 Messages postés mercredi 8 février 2017Date d'inscription 16 février 2017 Dernière intervention - 9 févr. 2017 à 08:44
Le résultat est obtenu par une simple formule =SOMME(D8:D14)
Si je mets la cellule en format Nombre ou Standart, le calcul des heures n'est plus exact.
Voilà le fichier en question : http://www.cjoint.com/c/GBjhRohbhzB
Merci d'avance. Sympa de m'aider.
Commenter la réponse de Vaucluse
Vaucluse 20872 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - 9 févr. 2017 à 10:53
0
Utile
3
Vu le fichier, mais je ne vois pas de problème en D15
si le total de B est supérieur à C le résultat est positif et la cellule est en vert
si le total de C est supérieur à B le résultat est négatif et la cellule est en vert
si B=C, la cellule D15 est blanche et n'affiche rien.
pouvez vous déposez un fichier dans l'état où apparait le problème?
SHAPE_OF_DESPAIR 7 Messages postés mercredi 8 février 2017Date d'inscription 16 février 2017 Dernière intervention - 9 févr. 2017 à 13:28
Incroyable ça.
SI B=C, la cellule D15 affiche -0:00:00 en rouge chez moi (alors qu'elle ne devrait rien afficher vu que j'ai décoché "Affiché un zéro dans les cellules ayant une valeur nulle", dans les options avancées.
Serait-ce un problème d'affichage lié à mon ordinateur.
Enfin, histoire d'en avoir le coeur net, ci-dessous le lien avec le fichier dans l'état où il pose problème. J'y ai joint un print sreen de ce que cela me donne.

http://www.cjoint.com/c/GBjmyOA0HBB
Vaucluse 20872 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - 9 févr. 2017 à 14:19
Non, le problème ne vient pas de votre PC, mais du fait (et c'est bien dommage) qu'Excel calcule les heures en fonction des fractions de jour par rapport un jour de 24h qui vaut 1 et que 12 minutes valent donc 12/1440
.
ce résultat est un nombre infini qu'Excel arrondi à la 16° décimale.

ce qui fait que -48/1440 ne correspond plus à la somme de 4 fois 12/1440

vous pouvez voir ça en formatant les cellules en "nombre" et 16 décimales.
Ecrivez alors par exemple en D6 (au même format) =SOMME(D8:D11)

et vous verrez la différence de résultat avec la cellule D12

Par ailleurs si vous faites =B15-C15, la valeur horaire étant la même vous retrouvez votre 0

Alors soit vous faites l'opération comme ci-dessus, soit vous calculez avec:
=ARRONDI(SOMME(D8:D14);15)

crdlmnt
SHAPE_OF_DESPAIR 7 Messages postés mercredi 8 février 2017Date d'inscription 16 février 2017 Dernière intervention - 9 févr. 2017 à 14:53
Merci Vaucluse.
Vous avez parfaitement raison.
En changeant =SOMME(D8:D14) par =B15-C15
Et bien tout rentre dans l'ordre.
Ça parait tellement simple quand on a la réponse !
Eh bien merci du coup de pouce et à bientôt.
Alain
Commenter la réponse de Vaucluse