Menu

Définir une lettre étant un chiffre (x=0) [Résolu/Fermé]

Jérémy Lafrenière - 8 févr. 2017 à 12:10 - Dernière réponse : JvDo 1813 Messages postés mercredi 27 juillet 2005Date d'inscription 5 avril 2018 Dernière intervention
- 8 févr. 2017 à 14:34
Bonjour,

Sur Excel 2016 sur Pc, Est-ce que c'est possible que lorsque j'écris la lettre ''x'' le logiciel prenne en considération que sa valeur est zéro?

Par exemple, j'ai une formule qui additionne bien des chiffres d'un programme d'entraînement, mais quand il y a un mouvement très dynamique, j'aimerais mettre un ''x'' au lieu d'un ''0''. Mais la formule rentre la lettre x et donc la rend invalide.

Merci :)
Afficher la suite 

6 réponses

Jm56Z 68 Messages postés mercredi 29 juin 2016Date d'inscription 6 juillet 2017 Dernière intervention - 8 févr. 2017 à 12:14
0
Utile
sur quel logiciel ?
Jm56Z 68 Messages postés mercredi 29 juin 2016Date d'inscription 6 juillet 2017 Dernière intervention - 8 févr. 2017 à 13:00
ça va être galère : il faut définir la constante X dans une case, et signaler à excel que désormais X=0. Mais si ça marche dans les programmes informatiques, je doute que ça fonctionne dans un tableur... Désolé !
JvDo 1813 Messages postés mercredi 27 juillet 2005Date d'inscription 5 avril 2018 Dernière intervention - 8 févr. 2017 à 13:08
0
Utile
Bonjour,

essaye
=SOMME.SI.ENS(B5:B11;B5:B11;"<>""x""")


j'ai supposé que ta zone de données était en B5:B11

cordialement
Jérémy Lafrenière - 8 févr. 2017 à 14:18
0
Utile
1
Merci beaucoup pour vos réponses, j'ai trouvé une solution simple:

1. Aller dans mise en forme conditionnelle
2. Nouvelle règle
3. Appliquer une mise en forme uniquement aux cellules qui contiennent
4. égale à: =0
5. Changer la mise en forme pour ''x''
JvDo 1813 Messages postés mercredi 27 juillet 2005Date d'inscription 5 avril 2018 Dernière intervention - 8 févr. 2017 à 14:34
Bonjour,

tu peux te passer de MFC pour afficher un "x" pour les valeurs nulles :
tu vas dans format de nombre personnalisé et tu choisis Standard;;"x"

cordialement