Signaler

Définir une lettre étant un chiffre (x=0) [Résolu]

Posez votre question Jérémy Lafrenière - Dernière réponse le 8 févr. 2017 à 14:34 par JvDo
Bonjour,

Sur Excel 2016 sur Pc, Est-ce que c'est possible que lorsque j'écris la lettre ''x'' le logiciel prenne en considération que sa valeur est zéro?

Par exemple, j'ai une formule qui additionne bien des chiffres d'un programme d'entraînement, mais quand il y a un mouvement très dynamique, j'aimerais mettre un ''x'' au lieu d'un ''0''. Mais la formule rentre la lettre x et donc la rend invalide.

Merci :)
Utile
+0
plus moins
sur quel logiciel ?
Donnez votre avis
Utile
+0
plus moins
Excel 2016 su PC!
Jm56Z 68Messages postés mercredi 29 juin 2016Date d'inscription 6 juillet 2017 Dernière intervention - 8 févr. 2017 à 13:00
ça va être galère : il faut définir la constante X dans une case, et signaler à excel que désormais X=0. Mais si ça marche dans les programmes informatiques, je doute que ça fonctionne dans un tableur... Désolé !
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

essaye
=SOMME.SI.ENS(B5:B11;B5:B11;"<>""x""")


j'ai supposé que ta zone de données était en B5:B11

cordialement
Donnez votre avis
Utile
+0
plus moins
Merci beaucoup pour vos réponses, j'ai trouvé une solution simple:

1. Aller dans mise en forme conditionnelle
2. Nouvelle règle
3. Appliquer une mise en forme uniquement aux cellules qui contiennent
4. égale à: =0
5. Changer la mise en forme pour ''x''
JvDo 1755Messages postés mercredi 27 juillet 2005Date d'inscription 19 septembre 2017 Dernière intervention - 8 févr. 2017 à 14:34
Bonjour,

tu peux te passer de MFC pour afficher un "x" pour les valeurs nulles :
tu vas dans format de nombre personnalisé et tu choisis Standard;;"x"

cordialement
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !