Signaler

Moyenne des transactions en fonction d’un mot et d’une période [Résolu]

Posez votre question btmachine 2Messages postés jeudi 12 janvier 2017Date d'inscription 13 janvier 2017 Dernière intervention - Dernière réponse le 13 janv. 2017 à 07:06 par Vaucluse
Bonjour,


Bonjour,
J’ai cherché un peu partout mais je n’ai pas trouvé de solution à mon problème.
Je cherche à faire une moyenne des transactions d’un relevé en fonction de deux critères distincts :

Premier critère, colonne A ; ‘la date’, je veux faire la moyenne sur une période donnée de l’année. (Cette partie fonctionne)

Deuxième critère, colonne B ‘L’intitulé’, je veux en plus avoir une condition en fonction de l’intitulé de la transaction.

Troisième colonne, les valeurs numériques de chaque transaction.

C’est lors de l’application de la deuxième condition que le calcul ne fonctionne plus.

Effectivement, le champ intitulé comporte souvent plusieurs mots et je souhaite faire une recherche sur seulement un ou deux mots de la phrase. Pour le moment, le résultat de la condition est toujours faux, malgré la présence du ou des mots dans le champ.

Je joint un exemple de la feuille de calcul.




=SOMMEPROD((MOIS(A21:A1015)=1)*(ANNEE(A21:A1015)=2016)*(B21:B1015="PRELEVEMENT")*C21:C1015)/(SOMMEPROD((B21:B1015="PRELEVEMENT")*(MOIS(A21:A1015)=1)*(ANNEE(A21:A1015)=2016)))



Merci de votre aide.
Afficher la suite 
Utile
+0
moins plus
Bonjour,
Sommeprod cherche une cellule qui contient le mot Prelevement et que ce mot là; Sommeprod n'accepte pas les caractères de remplacement ? ou *.
Il faudrait:
=SOMMEPROD((MOIS(A21:A1015)=12)*(ANNEE(A21:A1015)=2016)*(ESTNUM(CHERCHE("PRELEVEMENT";B21:B1015)))*C21:C1015)/(SOMMEPROD((ESTNUM(CHERCHE("PRELEVEMENT";B21:B1015)))*(MOIS(A21:A1015)=12)*(ANNEE(A21:A1015)=2016)))

Il serait certainement plus simple d'utiliser la fonction Moyenne.si.ens en utilisant comme critère "*PRELEVEMENT*" .
Donnez votre avis
Utile
+0
moins plus
Bonjour
et salut tontong
j'avais préparé ça pendant l'intervention de l'ami Tontong, ce qui confirme à mon avis que sa conclusion est la plus raisonable
http://www.cjoint.com/c/GAmmONAvmze
crdlmnt
btmachine 2Messages postés jeudi 12 janvier 2017Date d'inscription 13 janvier 2017 Dernière intervention - 13 janv. 2017 à 07:03
Super,
J'ai testé et ça marche très bien.
Merci à vous pour les réponses et votre réactivité.
Répondre
Vaucluse 18973Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 26 février 2017 Dernière intervention - 13 janv. 2017 à 07:06
Pas de quoi
Merci surtout à Tontong qui a soumis l'idée
Je passe le sujet en résolu
Bonne route
crdlmnt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !