Signaler

Recherche de valeurs - fonction rechercheV [Résolu]

Posez votre question urbades - Dernière réponse le 12 janv. 2017 à 16:56 par urbades
Bonjour,
Je m'arrache les cheveux depuis le début de la journée sur une formule et commence à désespérer...

J'ai 2 tableaux.
Dans le premier, j'ai notamment une liste de brèves, articles,...publiés sur un site internet (colonne E), ainsi qu'une colonne (la I) dans laquelle je souhaiterais avoir le nombre de vues de ces brèves, articles.
Dans un deuxième tableau (2ème feuille), j'ai réalisé un export de données issues d'un site internet. Après avoir fait des essais dans tous les sens, j'ai "nettoyé" ces données et me retrouve avec simplement 2 colonnes. Colonne A : du texte contenant le nom des brèves, articles,... (je dis contenant car il y a aussi d'autres info dans les cellules) et colonne B : le nombre de fois où ces brèves, articles,... ont été vus.
Pour récupérer cette info (nombre de vues), dans mon premier tableau j'ai essayé pas mal de formules. Et notamment

=RECHERCHEV(E39;rapports!A8:B256;2;VRAI)
E39 correspond au titre d'une brève
rapports!A8:B256 correspond au tableau de ma deuxième feuille contenant le texte en colonne A et le nombre de vues en colonne B
Mais je me retrouve avec la même valeur dans toutes les cases; celle située en bas de la colonne B de ma première feuille.

Autre tentative dans laquelle j'avais mis beaucoup d'espoir :
=SI(ESTERREUR(CHERCHE(E39;rapports!A8:A256));rapports!B8:B256;0)

Si l'un de vous a une idée... cela pourrait illuminer ma fin de journée, celle de demain, ou tout autre qui verrait la résolution de ce problème. Normalement, j'adore le casse tête que peut représenter excel mais là... je sèche.

Merci beaucoup!
Afficher la suite 
Utile
+1
plus moins
re

utilise
=RECHERCHEV("*"&E6&"*";rapports!A1:B249;2;0)

mais surtout, que les libellés soient identiques !
Cette réponse vous a-t-elle aidé ?  
Vaucluse 19624Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 24 mai 2017 Dernière intervention - 12 janv. 2017 à 16:50
+1 Djidji, tout particulièrement pour la dernière remarque, comme par exemple en ligne 22 avec la majuscule de Koweitïenne
Bien cordialement
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour ,
Quand on joint un fichier-test, (avec TOUTES les explications et les résultats souhaités) ou mieux, si c'est possible, le fichier concerné, c'est plus commode pour les intervenants.
Et tu as plus de chances que quelqu'un s’intéresse à ton problème

1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes s'affiche le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.
Donnez votre avis
Utile
+0
plus moins
Bonjour,

Merci pour ce retour.
Voici un extrait du fichier en question :
http://www.cjoint.com/doc/17_01/GAmkW2Yl7uG_suivi-partenariats---pb-de-formule.xlsx

J'ai tenté d'être le plus claire possible, si toutefois ce n'était pas le cas, je peux reprendre ma copie !

Merci bcp...
Donnez votre avis
Utile
+0
plus moins
Merci Djidji et Vaucluse !
Effectivement, cela fonctionne - pour les lignes dans lesquelles les libellés sont identiques. Je ne connaissais pas l'usage de "*"&E6&"*"
Je vais regarder cela de plus près...
En tous les cas, un très grand merci pour votre aide !
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !