Formule, additionner valeur si critère compris dans une liste [Résolu]

scelera 37 Messages postés lundi 10 juin 2013Date d'inscription 11 janvier 2017 Dernière intervention - 11 janv. 2017 à 14:28 - Dernière réponse : scelera 37 Messages postés lundi 10 juin 2013Date d'inscription 11 janvier 2017 Dernière intervention
- 11 janv. 2017 à 16:03
Bonjour,

Je cherche une formule qui me permettrais d’additionner des valeurs si une cellule répond au moins à un critère parmi une liste de plusieurs critères prédéfinis.
Par exemple dans le tableau ci dessous, j'aimerai additionner les valeurs en colonne B si les cellules en colonne A correspondent au moins à un critère de cet ensemble (oeil, bras, jambe).

Colonne A........................Colonne B
oeil..............................................2
tête..............................................1
jambe..........................................3

Merci beaucoup de votre aide !
Afficher la suite 
37Messages postés lundi 10 juin 2013Date d'inscription 11 janvier 2017 Dernière intervention

3 réponses

Répondre au sujet
ccm81 8204 Messages postés lundi 18 octobre 2010Date d'inscription 12 décembre 2017 Dernière intervention - 11 janv. 2017 à 15:19
0
Utile
2
Bonjour

Essaies ceci ( à adapter)

=SOMMEPROD((($A$2:$A$8="œil")+($A$2:$A$8="cou")+($A$2:$A$8="main"))*($B$2:$B$8))

Cdlmnt
scelera 37 Messages postés lundi 10 juin 2013Date d'inscription 11 janvier 2017 Dernière intervention - 11 janv. 2017 à 15:29
j'ai adapté la formule qui comprend 6 critères, sur des cellules allant de 6 à 280.
Les cellules ne sont pas encore remplie car elles le seront au fur et à mesure dans les mois à venir. Quand je tape la formule le résultat N/A apparaît je ne sais pas pourquoi.
Voici la formule en question:

=SOMMEPROD((('Plan-Détaillé'!$C$6:$C$280="oeil")+('Plan-Détaillé'!$C$6:$C$80="bras")+('Plan-Détaillé'!$C$6:$C$80="jambe et oeil")+('Plan-Détaillé'!$C$6:$C$80="tête")+('Plan-Détaillé'!$C$6:$C$80="tête et jambe")+('Plan-Détaillé'!$C$6:$C$280="pied"))*('Plan-Détaillé'!$I$6:$I$280))
scelera 37 Messages postés lundi 10 juin 2013Date d'inscription 11 janvier 2017 Dernière intervention > scelera 37 Messages postés lundi 10 juin 2013Date d'inscription 11 janvier 2017 Dernière intervention - 11 janv. 2017 à 16:03
Il y avait des erreurs de chiffres dans ma formule ! Cela fonctionne désormais !
Merci pour votre précieuse aide !
Commenter la réponse de ccm81