Menu

Double validation de données [Résolu/Fermé]

Lentzouille 666 Messages postés mardi 27 septembre 2011Date d'inscription 30 juin 2017 Dernière intervention - 10 janv. 2017 à 10:13 - Dernière réponse : Vaucluse 21867 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 avril 2018 Dernière intervention
- 10 janv. 2017 à 10:41
Bonjour à tous, et bonne année ! :)

J'avais une question concernant Excel, je souhaiterai mettre un message d'erreur si dans la même cellule le contenant n'est pas égal à 9 caractère et si le premier caractère n'est pas un chiffre,

Exemple :

123456789 = Pas de message
12345678 = Message d'erreur
a23456789 = Message d'erreur

Merci par avance,


Afficher la suite 

6 réponses

Vaucluse 21867 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 avril 2018 Dernière intervention - Modifié par Vaucluse le 10/01/2017 à 10:35
+2
Utile
2
Re
alors sil s'agit d'interdire l'entrée
Données/ validation
"personnaliser"
et entrez la formule, ex pour A2:
=ET(ESTNUM(GAUCHE(A2;1)*1);NBCAR(A2)=9)

dans les options , sous "alerte d'erreur" vous pouvez placer un message qui explique l'interdiction en cas d'affichage
crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Cette réponse vous a-t-elle aidé ?  
Lentzouille 666 Messages postés mardi 27 septembre 2011Date d'inscription 30 juin 2017 Dernière intervention - 10 janv. 2017 à 10:40
C'est parfait merci bien ! :)
Vaucluse 21867 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 avril 2018 Dernière intervention - 10 janv. 2017 à 10:41
Pas de quoi, je passe le sujet en résolu
Bonne route
crdlmnt
Vaucluse 21867 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 avril 2018 Dernière intervention - 10 janv. 2017 à 10:20
0
Utile
Bonjour
  • sous quelle forme le message d'erreur et où?
  • est une analyse de données déjà entrées ou une interdiction d'entrée à selon les critères?

à vous lire
PHILOU10120 4964 Messages postés lundi 16 avril 2012Date d'inscription 21 avril 2018 Dernière intervention - 10 janv. 2017 à 10:24
0
Utile
Bonjour Lentzouille

la cellule à contrôler est là A1 dans mon exemple

Dans la cellule à côté B1 mettre cette formule

=SI(NBCAR(A1)<9;"erreur incomplet";SI(OU(CODE(A1)<48;CODE(A1)>57);"erreur nombre";"Ok"))
Lentzouille 666 Messages postés mardi 27 septembre 2011Date d'inscription 30 juin 2017 Dernière intervention - 10 janv. 2017 à 10:26
0
Utile
A la base j'étais passé par la validation des données,

Du coup le message se mettait automatiquement si le critère de 9 caractères n'était pas présent.

Pour la 2nde question je ne l'ai pas comprise, la personne rentre dans la cellule indique un code, si ce code ne commence par un chiffre et ne comprend pas 9 caractère alors le message d'erreur intervient à ce moment

Merci,