Signaler

Extraction de chaines de cractères à valeur précises (ex: 10) [Résolu]

Posez votre question H.167 9Messages postés lundi 9 janvier 2017Date d'inscription 18 janvier 2017 Dernière intervention - Dernière réponse le 9 janv. 2017 à 11:39 par H.167
Bonjour,

j'ai intégré un dictionnaire sur excel, d'une valeur de 5000 mots,
j'aimerais simplement savoir s'il serait possible d'extraire d'une façon ou d'une autre seulement les mots avec une valeur définie de lettres (ex : ceux de 10 lettres )
j'ai cherché, mais je n'ai rien trouvé.

Merci d'avance pour toute aide apportée
Cordialement
H
Utile
+1
plus moins
Bonjour

extraction directe en F selon le nombre de caractères inscrit en F1

http://www.cjoint.com/c/GAjhxNJjidC

et le même si besoin, avec renvoi des liens

http://www.cjoint.com/c/GAjh6EQbNXC

crdlmnt

Cette réponse vous a-t-elle aidé ?  
Donnez votre avis
Utile
+0
plus moins
Bonjour.

Oui, très probablement ...
Si on avait un fichier contenant un extrait de ce dictionnaire, on pourrait proposer une formule ou une méthodologie !
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse
tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint
Donnez votre avis
Utile
+0
plus moins
Merci pour la réponse très rapide : )
voila le lien : http://www.cjoint.com/c/GAjaHIo8Gp3

merci bcp
Utilisateur anonyme - 9 janv. 2017 à 01:52
 
Bonjour H.167,

Je te retourne ton fichier Excel 2007 modifié.

Voici la formule de C2 : =SI(ET(A2>0;B2<>"");NBCAR(B2);"")

Je l'ai tirée vers le bas jusqu'en C5010 ; tu devras la tirer
plus bas quand ce sera nécessaire.

Tu verras qu'il y a un filtre sur le nombre de caractères,
tel que seuls les mots de 10 lettres apparaissent, mais
les autres sont toujours présents.

Tu peux choisir un autre critère de filtre, tel que les mots de
8 lettres ; tu peux même choisir : « entre 6 et 12 lettres ».

Pour enlever le filtre : onglet Données, groupe « Trier et filtrer »,
clique sur le gros entonnoir pour qu'il ne soit plus en orange.

C'est valable pour une simple consultation, mais si tu veux
vraiment une extraction, c'est aussi possible.

Cordialement.  :)
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour H.167

Vu ton absence de directives "... savoir s'il serait possible d'extraire d'une façon ou d'une autre ", je te propose une autre présentation, sous forme de tableau : http://www.cjoint.com/c/GAjeuMGKn4M
Donnez votre avis
Utile
+0
plus moins
Bonjour,
merci énormément pour toute l'aide apportée,
je bloquais vraiment sur ce problème

Cordialement
H.167
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !