Remplir une case selon 3 conditions [Résolu]

MatyLou 7 Messages postés samedi 7 janvier 2017Date d'inscription 7 janvier 2017 Dernière intervention - 7 janv. 2017 à 13:16 - Dernière réponse : MatyLou 7 Messages postés samedi 7 janvier 2017Date d'inscription 7 janvier 2017 Dernière intervention
- 7 janv. 2017 à 15:53
Bonjour,
J'ai fait le tour de plusieurs forum et je ne trouve pas ma formule magique! :)
Je vais tenter de m'expliquer clairement:
Je souhaite avoir une formule qui met automatiquement dans la cellule Q
- Soit un X si la cellule B est remplie et si la cellule C est vide.
- Soit rien si la cellule B est vide
- Soit rien si la cellule B est remplie et la C est également remplie

J'ai trouvé ma formule pour la cellule P, mais avec 3 conditions je n'y arrive pas.

Je vous remercie

Afficher la suite 

9 réponses

Répondre au sujet
jb.lugherini 974 Messages postés dimanche 18 mars 2007Date d'inscription 14 mars 2017 Dernière intervention - 7 janv. 2017 à 13:25
+1
Utile
Bonjour,

=SI(ESTVIDE(B4);"RIEN";SI(ESTVIDE(C4);"X";"RIEN"))
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de jb.lugherini
Vaucluse 20862 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - 7 janv. 2017 à 13:24
0
Utile
2
Bonjour

=SI(OU(B2="";ET(B2<>"";C2<>""));"";"X")

quant à la condition pour P, quelle est elle?

crdlmnt
MatyLou 7 Messages postés samedi 7 janvier 2017Date d'inscription 7 janvier 2017 Dernière intervention - 7 janv. 2017 à 14:06
Pour la Cellule P, j'ai utilisé la formule =SI(ESTVIDE(B4);"X";""). Je voulais qu'un "X" apparaisse dans la cellule P si la Cellule C est vide, sinon rien.
MatyLou 7 Messages postés samedi 7 janvier 2017Date d'inscription 7 janvier 2017 Dernière intervention - 7 janv. 2017 à 14:12
J'ai un autre soucis, tjs avec le même dossier, pour ma cellule R

J'ai essayé: =SI(ESTVIDE(A4);"";SI(ESTVIDE(B4);"";DATEDIF(A4:B4;"m")))
Mais j'ai un message Err:511 qui apparaît.

j'aimerais pour cette cellule (R), calculer le nombre de jour (et non mois "m") entre la cellule A et B, mais uniquement s'il y a une date dans la cellule B.
Il me faut un format nombre car ensuite je dois calculer la moyenne.

cordialement
Commenter la réponse de Vaucluse
MatyLou 7 Messages postés samedi 7 janvier 2017Date d'inscription 7 janvier 2017 Dernière intervention - 7 janv. 2017 à 13:30
0
Utile
Super! Merci beaucoup pour votre réponse aussi rapide qui fonctionne exactement comme je le souhaitais!
Commenter la réponse de MatyLou
MatyLou 7 Messages postés samedi 7 janvier 2017Date d'inscription 7 janvier 2017 Dernière intervention - 7 janv. 2017 à 14:14
0
Utile
3
J'ai un autre soucis, tjs avec le même dossier, pour ma cellule R

J'ai essayé: =SI(ESTVIDE(A4);"";SI(ESTVIDE(B4);"";DATEDIF(A4:B4;"m")))
Mais j'ai un message Err:511 qui apparaît.

j'aimerais pour cette cellule (R), calculer le nombre de jour (et non mois "m") entre la cellule A et B, mais uniquement s'il y a une date dans la cellule B.
Il faut que la case soit vide si A et/ou B sont vide et il me faut un format nombre car ensuite je dois calculer la moyenne total de ma colonne R.

Merci
jb.lugherini 974 Messages postés dimanche 18 mars 2007Date d'inscription 14 mars 2017 Dernière intervention - 7 janv. 2017 à 14:27
Voici la formule corrigée
=SI(ESTVIDE(A4);"";SI(ESTVIDE(B4);"";DATEDIF(A4;B4;"D")))

Cordialement,
MatyLou 7 Messages postés samedi 7 janvier 2017Date d'inscription 7 janvier 2017 Dernière intervention > jb.lugherini 974 Messages postés dimanche 18 mars 2007Date d'inscription 14 mars 2017 Dernière intervention - 7 janv. 2017 à 15:39
:( Ca ne marche pas!
Ca me donne une date et ca ne me calcule pas le nombre de jours d'écart entre la cellule A et B.

Merci
MatyLou 7 Messages postés samedi 7 janvier 2017Date d'inscription 7 janvier 2017 Dernière intervention > jb.lugherini 974 Messages postés dimanche 18 mars 2007Date d'inscription 14 mars 2017 Dernière intervention - 7 janv. 2017 à 15:53
Alors suis trop mauvaise aujourd'hui!!!... Ta formule marche très bien, je n'ai juste pas formaté ma cellule comme il fallait!
Merci bcp.
Commenter la réponse de MatyLou