Signaler

Condition si et suppression 0 [Résolu]

Posez votre question BESOINDAIDEEXCEL 6Messages postés jeudi 5 janvier 2017Date d'inscription 5 janvier 2017 Dernière intervention - Dernière réponse le 5 janv. 2017 à 22:34 par BESOINDAIDEEXCEL
Bonsoir,

Dans le tableau ci-dessous je calcule l'écart entre le prév et le réel en %.
j'ai malheureusement des 0 que je souhaite garder (prev 0, réel 0 écart 0%) et des cases vides que je souhaite garder vide en résultat. comment puis je faire svp?

Merci d'avance


Afficher la suite 
Utile
+0
plus moins
Bonjour,

Avec cette formule :
 =SI(A1="";"";SI(A1=0;0;(B1-A1)/A1))
BESOINDAIDEEXCEL 6Messages postés jeudi 5 janvier 2017Date d'inscription 5 janvier 2017 Dernière intervention - 5 janv. 2017 à 21:24
Merci mais les conditions sont pour A1 et B1 à la fois.pour le 0 et le rien.
Avez vous une autre idée ?

Merci
Répondre
gbinforme 13734Messages postés lundi 18 octobre 2004Date d'inscription ContributeurStatut 23 mai 2017 Dernière intervention - 5 janv. 2017 à 21:43
re
Tu remplaces A1 et B1 par les cellules "prev" et "réel" correspondantes bien sûr et tu mets ta formule dans "écart"
Répondre
BESOINDAIDEEXCEL 6Messages postés jeudi 5 janvier 2017Date d'inscription 5 janvier 2017 Dernière intervention - 5 janv. 2017 à 21:49
re,

C'est bien le résultat qui m'intéresse et en fonction du chiffre que me donne l'écart (le résultat) je souhaite avoir le résultat ou 0% si (0+0) ou "" si je n'ai rien dans les deux cases précédentes.

merci d'avance
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

Cela ne répond pas à ta demande ?

http://www.cjoint.com/c/GAfu7BcKnZl
BESOINDAIDEEXCEL 6Messages postés jeudi 5 janvier 2017Date d'inscription 5 janvier 2017 Dernière intervention - 5 janv. 2017 à 22:13
malheuresement non car si j'ai 0 en A1 et 2 en B1 ca ne fonctionne pas dans ce cas
je mets un schéma
Répondre
Donnez votre avis
Utile
+0
plus moins


c
gbinforme 13734Messages postés lundi 18 octobre 2004Date d'inscription ContributeurStatut 23 mai 2017 Dernière intervention - 5 janv. 2017 à 22:30
re
Comme l'écart se fait avec "prev" en diviseur tu ne peux obtenir que zéro ou une erreur (Jusqu'à preuve du contraire !)
Répondre
BESOINDAIDEEXCEL 6Messages postés jeudi 5 janvier 2017Date d'inscription 5 janvier 2017 Dernière intervention - 5 janv. 2017 à 22:34
biensur vous avez raison merci bcp pour votre aide.
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !