Signaler

Formule conditionnelle [Résolu]

Posez votre question MarieLeaCharlotte 3Messages postés jeudi 5 janvier 2017Date d'inscription 11 janvier 2017 Dernière intervention - Dernière réponse le 5 janv. 2017 à 17:04 par ccm81
Bonjour à tous,

Dans notre tableau Excel nous avons une colonne "nom fournisseur" et une deuxième "code fournisseur". Nous souhaitons que lorsqu'on rentre le nom du fournisseur, le code s'affiche automatiquement. Le code est toujours du type "C" suivi d'un nombre. Le premier code sera alors C1, puis C2 etc. ...
Pour cela, nous avons utilisé une formule conditionnelle du type : SI(ESTTEXTE(A3);"C1";""). Sauf que quand nous l'appliquons aux autres cellules, il est à chaque fois affiché C1. Comment peut on faire pour incrémenter de 1 à chaque cellule de la colonne et obtenir de ce fait, C1, C2 ...

Merci par avance !
Afficher la suite 
Utile
+0
moins plus
Bonjour

Essaies ceci

A commencer en ligne 3
=SI(ESTTEXTE(A3);"C" & LIGNE()-2;"")

ou si les cellules non texte colonne A sont vides ou numériques
=SI(ESTTEXTE(A3);"C" & NBVAL($A$3:$A3)-NB($A$3:$A3);"")

Cdlmnt
MarieLeaCharlotte 3Messages postés jeudi 5 janvier 2017Date d'inscription 11 janvier 2017 Dernière intervention - 5 janv. 2017 à 16:24
Ca marche !

Merci beaucoup !!!

Bonne journée.
Répondre
Donnez votre avis
Utile
+0
moins plus
De rien

Si c'est fini, peux tu mettre le sujet à résolu (en dessous du titre de ton premier message)


Bonne fin de journée
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !