Formule conditionnelle [Résolu/Fermé]

MarieLeaCharlotte 3 Messages postés jeudi 5 janvier 2017Date d'inscription 11 janvier 2017 Dernière intervention - 5 janv. 2017 à 15:32 - Dernière réponse : ccm81 8223 Messages postés lundi 18 octobre 2010Date d'inscription 6 janvier 2018 Dernière intervention
- 5 janv. 2017 à 17:04
Bonjour à tous,

Dans notre tableau Excel nous avons une colonne "nom fournisseur" et une deuxième "code fournisseur". Nous souhaitons que lorsqu'on rentre le nom du fournisseur, le code s'affiche automatiquement. Le code est toujours du type "C" suivi d'un nombre. Le premier code sera alors C1, puis C2 etc. ...
Pour cela, nous avons utilisé une formule conditionnelle du type : SI(ESTTEXTE(A3);"C1";""). Sauf que quand nous l'appliquons aux autres cellules, il est à chaque fois affiché C1. Comment peut on faire pour incrémenter de 1 à chaque cellule de la colonne et obtenir de ce fait, C1, C2 ...

Merci par avance !
Afficher la suite 

3 réponses

ccm81 8223 Messages postés lundi 18 octobre 2010Date d'inscription 6 janvier 2018 Dernière intervention - Modifié par ccm81 le 5/01/2017 à 16:28
0
Utile
1
Bonjour

Essaies ceci

A commencer en ligne 3
=SI(ESTTEXTE(A3);"C" & LIGNE()-2;"")

ou si les cellules non texte colonne A sont vides ou numériques
=SI(ESTTEXTE(A3);"C" & NBVAL($A$3:$A3)-NB($A$3:$A3);"")

Cdlmnt
MarieLeaCharlotte 3 Messages postés jeudi 5 janvier 2017Date d'inscription 11 janvier 2017 Dernière intervention - 5 janv. 2017 à 16:24
Ca marche !

Merci beaucoup !!!

Bonne journée.
ccm81 8223 Messages postés lundi 18 octobre 2010Date d'inscription 6 janvier 2018 Dernière intervention - 5 janv. 2017 à 17:04
0
Utile
De rien

Si c'est fini, peux tu mettre le sujet à résolu (en dessous du titre de ton premier message)


Bonne fin de journée