Signaler

Calcul automatique avec des conditions [Résolu]

Posez votre question BlueNibben - Dernière réponse le 4 janv. 2017 à 15:56 par BlueNibben
Bonjour,

Totalement novice avec Excel, je voudrais pourtant m'en servir pour tenir un compte automatisé ou presque de mes résidents chuteurs.
A ce jour, j'ai donc utilisé les quelques formules que je connais mais je n'arrive pas à trouver tout ce que je veux, d'où ma présence.

Dans mon fichier, j'ai :
  • une liste de tous les résidents qui ont fait une chute au moins l'année dernière, avec en A = NOM, en B = PRENOM et en C = total des chutes annuel
  • ensuite, j'ai douze petits tableaux mensuels avec :

- F : NOM et G : PRENOM - uniquement des patients qui ont une chute déclarée dans le mois, je ne reprends pas la liste entière de l'établissement. La liste change d'un mois à l'autre.
- de H à Q les dates des chutes éventuelles (en format date)
- en R le total des chutes par personne pour chaque mois (avec la formule NB)
- en fin de colonne : nombre de patients chuteurs, nombre de patients ayant fait au moins 2 chutes (avec NBVAL) et nombre total de chutes du mois
  • un récapitulatif avec mon total de chutes par mois, mon total de chutes survenues chez des récidivistes (obtenu avec SOMME.SI, une première !), mon total de patients et mon total de récidivistes.

Je souhaiterais que le document me fasse le calcul du nombre de chutes annuel de chaque personne, avec quelque chose que j'imagine comme "si NOM + PRENOM sont présents sur la ligne alors additionner le total de la colonne R des douze petits tableaux", et qu'il me remplisse cette foutue case C tout seul car l'année dernière j'avais les yeux qui se croisaient à force.

Merci d'avance pour votre aide, vos conseils et votre soutien :D
Afficher la suite 
Utile
+1
plus moins
Bonjour,

Tous les tableaux mensuels sont sur les mêmes colonnes de F à R ?

Si oui, une utilisation de somme.si.ens devrait fonctionner :
en C2 : =SOMME.SI.ENS(R:R;F:F;A2;G:G;B2).

Bonne journée,
-NoeGo-
Cette réponse vous a-t-elle aidé ?  
BlueNibben- 4 janv. 2017 à 15:56
Pour l'instant ils sont sur deux rangées, mais j'imagine que je peux les regrouper si ça me facilite la vie !
Je viens de tester sur mon modèle anonymisé, cela fonctionne à merveille !
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjouir
pour simplifier le problème, anonymiser si besoin les noms de votre fichier , ajotezé quelques, explications, et déposez, le sur:
http://www.cjoint.com
créez le lien sur le site et revenez le coller ici
à vous lire
crdlmnt
BlueNibben- 4 janv. 2017 à 15:51
Mon fichier ressemble à ceci pour le moment :
http://www.cjoint.com/c/GAeoYKw60cA

Est-ce plus parlant pour vous ?
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !