Signaler

Comparaison de plusieurs valeurs - Formule [Résolu]

Posez votre question LFPO26 - Dernière réponse le 5 janv. 2017 à 14:24 par LFPO26
Salut à tous,

Je suis en train de faire un tableau pour le travail, qui en mettant une valeur, indiquera si il y a un problème ou pas.

Le truc c'est que la valeur mise dépendra de deux valeurs:

Valeur DRY: avec une valeur de référence et une tolérance
Exemple
Valeur réf: 70
Tolérance: +/- 1
Donc 69 => 71

Et idem pour la valeur WET
Exemple
Valeur réf: 80
Tolérance: +/- 0.50
Donc 79,50 => 80,50

Et je souhaiterai faire une formule complète avec la valeur DRY et WET, comme ça, lorsque la personne met la valeur, il indiquera tout de suite si il y a un problème ou pas.

J'ai essayé cette formule:

=SI(ET(F6>=69,59;F6<=70,99);"OK";"NOT OK")

Les chiffres indiqués sont les chiffres directement calculés avec la tolérance en moins et en plus.

Comment rajouter l'autre valeur ?

Merci beaucoup !
Utile
+0
plus moins
Bonjour
reste à savoir où se troue l'info DRY ou WET? et aussi pourquoi vous parlez de 69,59 dans votre formule?
pour le principe
valeur en F6 / type DRY ou WET en G6 à adapter:

=SI(OU(ET(G6="DRY";F6>=69;F6<=71);ET(G6="WET";F6>=79,5;F6<=80,5));"OK";"NOK")

crdlmnt
Donnez votre avis
Utile
+0
plus moins
Le 69.59 c'est une erreur en fait, il faut lire 69 et 71.

Le dry et le wet sont des valeurs de référence dans une colonne spécifique.
A droite de ces colonnes, il y a la tolérance.
Puis encore à droite, il y a la valeur que l'utilisateur va mettre.
Pour finir, il y a la colonne où se trouve cette formule et où je galère...

Dans ma formule initiale, en fait j'avais mis les valeurs avec la tolérance appliquées sinon ça devient compliqué.
Vaucluse 20342Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 19 septembre 2017 Dernière intervention - 4 janv. 2017 à 11:42
Re
alors en principe, si le DRY ou le WET sont définis par la valeur dans une colonne ( donc 70 ou 80), la formule doit pouvoir se passer de l'indication de tolérance dans une cellule spécifique, d'autant plus que si vous inscrivez +/- 1 dans une cellule, c'est du texte qu'Excel ne peut paas utiliser en calcul.

Mais comme vous ne dites toujours pas dans quelles colonnes sont vos infos, on ne peut que vous proposer d'adapter:

G6< valeur spécifique 70 ou 80
=SI(OU(ET(G6=70;F6>=69;F6<=71);ET(G6=80;F6>=79,5;F6<=80,5));"OK";"NOK")

et si vous voulez vraiment utiliser une colonne tolérance, et que celles ci sont centrées n'utilisez que la valeur num

exemple
D6: type 70 ou 80
E6: valeur de la tolérance: avec cette formule:
=SI(E6=70;1;SI(E6=80;0,5;"")
F6 valeur à analyser
G6:
=SI(ET(F6>=E6-D6;F6<=D6+E6);"OK";"NOK")

crdlmnt
Répondre
LFPO26- 4 janv. 2017 à 12:06
Oui, en fait, c'est compliqué comme j'ai fait.

En fait, voici les colonnes:

Dans la D, il y a la référence DRY
Dans la E, il y a la référence WET
Dans la F, il y a la valeur de la tolérance

Dans la G, il y a valeur que l'utilisateur va mettre
Et dans la H, le résultat avec la formule.

Y'a t'il une formule possible pour qu'il calcule la valeur DRY avec la tolérance (en positif et en négatif), pareil pour la WET et que le résultat, si il est bon, il écrit OK en VERT et pas bon, NOT OK en rouge ?

Et que de base, sans aucune valeur utilisateur (la G), la colonne H soit vide.
Répondre
Donnez votre avis
Utile
+0
plus moins
C'est bon, j'ai réussi grâce à ta formule que j'ai modifié légèrement.

=SI(OU(ET(G6>=69,59;G6<=70,99);ET(G6>=146,14;G6<=147,54));"OK";"NOT OK")

J'ai mis les valeurs que je souhaitais.

Par contre, lorsque je mets rien dans la case utilisateur et que c'est vide, la case avec formule, écrit par défaut, NOT OK. Comment mettre la case blanche ?
Est-ce possible de rajouter le NOT OK en rouge lorsque la valeur n'est pas bonne, automatiquement ?
Vaucluse 20342Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 19 septembre 2017 Dernière intervention - 4 janv. 2017 à 12:33
Pour éviter un affichage par défaut en H

=SI(G6="";"";SI(OU(ET(G6>=69,59;G6<=70,99);ET(G6>=146,14;G6<=147,54));"OK";"NOT OK"))

Pour mettre en forme la cellule selon le résultat
  • sélectionnez le champ à traiter (on suppose qu'il démarre en H6)
  • ruban / onglet accueil / Icone mise en forme conditionnelle
  • dans la liste qui s'affiche: "nouvelle règle"
  • dans la fenêtre suivante

"utiliser une formule....)
  • entrez dans le cadre formule:


=G6="OK"
  • cliquez sur format/ remplissage vert
  • OK dans la fenêtre format
  • on revient à la fenêtre de MFC
  • en haut "nouvelle règel"

et

G6="NOK"
  • formatez en rouge
  • et fermez tout pas OK / OK


crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Merci pour ton retour !

J'ai réussi pour faire disparaître le NOT OK en standard, mais pas la couleur, ça ne marche pas...

J'ai remarqué que comme ça la formule est compliquée car je dois me taper toutes les valeurs par ligne et y'en a pas mal...

Y'a t'il une formule possible pour qu'il calcule la valeur DRY avec la tolérance (en positif et en négatif), pareil pour la WET et que le résultat, si il est bon, il écrit OK en VERT et pas bon, NOT OK en rouge ?

Et que de base, sans aucune valeur utilisateur (la G), la colonne H soit vide.

En fait, voici les colonnes:

Dans la D, il y a la référence DRY
Dans la E, il y a la référence WET
Dans la F, il y a la valeur de la tolérance

Dans la G, il y a valeur que l'utilisateur va mettre
Et dans la H, le résultat avec la formule.
LFPO26- 4 janv. 2017 à 14:10
Voici le lien:

http://www.cjoint.com/c/GAenjk02smS

J'ai fait le maximum que j'ai pu, mais si c'est possible de rendre moins compliqué mes formules et l'histoire du fond vert/rouge ça serait cool car j'ai vraiment dû mal...

Merci !
Répondre
Vaucluse 20342Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 19 septembre 2017 Dernière intervention - 4 janv. 2017 à 15:21
vous êtes dans votre domaine et avez beaucoup de mal à comprendre qu'on ne sait pas de quoi vous parlez!

A quoi sert votre formule en G8? quel est le lien entre la valeur de tolérance indiquée et la colonne F?quels sont les liens entre D,E,F et la formule?

mais si la formule à limite fixes en H vous convient, voila votre fichier avec les mise en forme correspondant à votre demande
voyez les régles dans la fenêtre de MFC

http://www.cjoint.com/c/GAeoAqsDWCP


En complément, voyez la formule dans la colonne J qui elle, s'ajuste à chaque fois sur la ligne où elle se trouve en situant G dans les, fourchettes de tolérance selon les valeurs variables sur chaque ligne (mais bien sur ne donne pas le même résultat)
et en complément la K qui ressort la catégorie dans la quelle se trouve la valeur de G
crdlmt
Répondre
LFPO26- 5 janv. 2017 à 12:16
Merci, ça a l'air bien.
J'essaye d'expliquer par rapport à ce que je connais sur Excel et pas simple de le faire quand on ne le maîtrise pas...
J'ai un peu modifié par rapport à mes besoins car il y a un truc qui vient de changer.

Par contre, comment faire pour que les éléments à partir de B8 à B47 se mettent en fond rouge lorsque les éléments de H8 à H47 se mettent en NOT OK ?
Idem pour OK

Merci !
Répondre
LFPO26- 5 janv. 2017 à 12:31
De plus, j'ai créé un nouvel onglet et j'ai appliqué la formule modifiée.
Par contre, j'ai essayé de créer les règles pour les OK/NOT OK de la colonne H et ils ne veut pas prendre...
Je me suis trompé quelque part ?

Fichier mis à jour
http://www.cjoint.com/c/GAflCpFeJRS
Répondre
Vaucluse 20342Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 19 septembre 2017 Dernière intervention - 5 janv. 2017 à 12:43
Bonjour

1° question pour formater la colonne B

conservez la formule en H. pour les deux. Si vous écrivez B8="OK" ça ne peut pas fonctionner puisque B ne prend jamais cette valeur

dans la fenêtre de MFC:

la formule

H8="OK" ou H8="NON OK" doit être bloquée avec le signe $pour la colonne, de façon à pouvoir s'appliquer sur une autre colonne

donc:
=$H8="OK" et $H8="NON OK"

ensuite dans la fenêtre de MFC vous avez la case à droite qui précise l'adresse où elle s'applique
entrez y:
$H$8:$H$47;$B$8:$B47
attention à tous les signes aux bons endroits

2° question
ce qui ne fonctionne pas, c'est que votre formule de MFC est la même pour le vert et le rouge, soit
=H8="NON OK" alors que le vert devrait être =H8="Ok"

crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Très gentil de ta part, ça a l'air de fonctionner, j'ai mis à ma "sauce" et tout fonctionne !

Merci pour ta patience et ton aide !
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !