Aide au reporting [Résolu]

LéoTaba - 29 déc. 2016 à 10:39 - Dernière réponse :  LéoTaba
- 30 déc. 2016 à 07:25
Bonjour,
j'ai un reporting annuel a faire a partir de feuilles mensuelles; comment pourrais-je faire étant donné que la formule INDIRECT a des limites : http://www.cjoint.com/c/FLDjLpAMFGl

Cordialement et dans l'attente d'une main venu du ciel, Léo.
Afficher la suite 

6 réponses

Répondre au sujet
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - Modifié par Vaucluse le 29/12/2016 à 11:26
0
Utile
Bonjour Leo...

la main en question n'aura pas beaucoup de chemin à faire, INDIRECT fonctionnant très bien (c'est Noël; il faut y croire!)
par exemple en D2 de la feuille reporting:

=INDIRECT(D$1&"_2016!C1") devrait faire l'affaire, de même qu'en D3:

=INDIRECT(D$1&"_2016!C2")

et si vous avez le N° de l'année en A1 dans cette feuille vous pouvez simplement écrire:

=INDIRECT(D$1&"_"&$A$1&"!C1")

petit rappel:
vous pouvez tester pour construire une adresse indirecte, directement dans une cellule hors champ
=D$1&"_2016!C1" vous affichera exactement ce que INDIRECT va prendre en compte

crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Commenter la réponse de Vaucluse
gbinforme 14415 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - 29 déc. 2016 à 11:39
0
Utile
Bonjour LéoTaba,

Le classeur avec les formules qui permettent de changer d'année :

http://www.cjoint.com/c/FLDkJsMaJWl

@ Vaucluse : Bonjour à toi c'est ta partition que j'ai mis en musique !
bonne fin d'année.
Commenter la réponse de gbinforme
PHILOU10120 4707 Messages postés lundi 16 avril 2012Date d'inscription 12 décembre 2017 Dernière intervention - 29 déc. 2016 à 11:43
0
Utile
Bonjour Léotaba

Votre fichier modifié

http://www.cjoint.com/c/FLDkQYF6Nwx
Commenter la réponse de PHILOU10120
0
Utile
2
Merci a vous 3 pour votre aide vous pouvez pas savoir la taille de l'épine dans l'pied que vous me sortez.
Et si dans :
=INDIRECT(D$1&"_"&$A$1&"!C1")
je ne veux pas la cellule C1 mais la moyenne de C5 à F5 que dois je écrire sachant que
=INDIRECT(D$1&"_"&$A$1&"!MOYENNE(C5:F5)")
ne fonctionne pas ?
Cdlmt
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 29 déc. 2016 à 16:20
Re

=MOYENNE(INDIRECT(D$1&"_"&$A$1&"!C5:F5"))

crdlmnt
Commenter la réponse de LéoTaba