Signaler

Aide au reporting [Résolu]

Posez votre question LéoTaba - Dernière réponse le 30 déc. 2016 à 07:25 par LéoTaba
Bonjour,
j'ai un reporting annuel a faire a partir de feuilles mensuelles; comment pourrais-je faire étant donné que la formule INDIRECT a des limites : http://www.cjoint.com/c/FLDjLpAMFGl

Cordialement et dans l'attente d'une main venu du ciel, Léo.
Afficher la suite 
Utile
+0
plus moins
Bonjour Leo...

la main en question n'aura pas beaucoup de chemin à faire, INDIRECT fonctionnant très bien (c'est Noël; il faut y croire!)
par exemple en D2 de la feuille reporting:

=INDIRECT(D$1&"_2016!C1") devrait faire l'affaire, de même qu'en D3:

=INDIRECT(D$1&"_2016!C2")

et si vous avez le N° de l'année en A1 dans cette feuille vous pouvez simplement écrire:

=INDIRECT(D$1&"_"&$A$1&"!C1")

petit rappel:
vous pouvez tester pour construire une adresse indirecte, directement dans une cellule hors champ
=D$1&"_2016!C1" vous affichera exactement ce que INDIRECT va prendre en compte

crdlmnt
Donnez votre avis
Utile
+0
plus moins
Bonjour LéoTaba,

Le classeur avec les formules qui permettent de changer d'année :

http://www.cjoint.com/c/FLDkJsMaJWl

@ Vaucluse : Bonjour à toi c'est ta partition que j'ai mis en musique !
bonne fin d'année.
Donnez votre avis
Utile
+0
plus moins
Bonjour Léotaba

Votre fichier modifié

http://www.cjoint.com/c/FLDkQYF6Nwx
Donnez votre avis
Utile
+0
plus moins
Merci a vous 3 pour votre aide vous pouvez pas savoir la taille de l'épine dans l'pied que vous me sortez.
Et si dans :
=INDIRECT(D$1&"_"&$A$1&"!C1")
je ne veux pas la cellule C1 mais la moyenne de C5 à F5 que dois je écrire sachant que
=INDIRECT(D$1&"_"&$A$1&"!MOYENNE(C5:F5)")
ne fonctionne pas ?
Cdlmt
Vaucluse 20182Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 21 août 2017 Dernière intervention - 29 déc. 2016 à 16:20
Re

=MOYENNE(INDIRECT(D$1&"_"&$A$1&"!C5:F5"))

crdlmnt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !