Signaler

Agrémenter une formule de 1 toute les 3 lignes

Posez votre question MargotMP 3Messages postés vendredi 2 décembre 2016Date d'inscription 2 décembre 2016 Dernière intervention - Dernière réponse le 2 déc. 2016 à 12:38
Bonjour !

Je viens chercher un petit peu d'aide car je n'arrive pas à composer une formule...

Je cherche à agrémenter une formule de recherche de noms d'onglets d'un classeur toutes les 3 lignes de la même façon que si on étirait juste la cellule...
J'ai trouvé sur internet la formule DECALER mais n'arrive pas à l'assembler à ma formule existante.

voici ma formule de base : =SI(LIGNES($1:2)<=NBVAL(NOMFEUILLES);INDEX(NOMFEUILLES;LIGNES($1:2));"")

Ce n'est peut-être pas très claire...ci-joint une feuille d'exemple...

Merci d'avance pour votre aide !
Afficher la suite 
Utile
+0
moins plus
Bonjour,

ci-joint une feuille d'exemple...

Pour communiquer ton classeur tu le télécharges sur http://cjoint.com/ (mode d'emploi) et tu mets ici le lien obtenu.
MargotMP 3Messages postés vendredi 2 décembre 2016Date d'inscription 2 décembre 2016 Dernière intervention - 2 déc. 2016 à 10:12
Dsl, j'ai cru que ça avait fonctionné !
voici le lien http://www.cjoint.com/c/FLcjjoOmjwE
merci pour le tuyau
Répondre
Vaucluse 18256Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 2 décembre 2016 Dernière intervention - 2 déc. 2016 à 11:00
Bonjour
en attendant l'ami Gb (salut) qui fera sans doute mieux, essayez en rempaçant LIGNE(1:2) en A3 par:
=ENT((LIGNE(A4=)/4)+1

ou encore plus court pour commencer à 2

=ENT(LIGNE(A8)/4)

crdlmnt
Répondre
MargotMP 3Messages postés vendredi 2 décembre 2016Date d'inscription 2 décembre 2016 Dernière intervention - 2 déc. 2016 à 12:03
Bonjour,
donc formule complète serait :
=SI((ENT((LIGNE(A4=)/4)+1))<=NBVAL(NOMFEUILLES);INDEX(NOMFEUILLES;(ENT((LIGNE(A4=)/4)+1));""))
??
si oui, ça me renvoi vers le "=" après le A4, si je le supprime ça me renvoi #VALEUR!...
ou alors j'ai pas compris ce que vous vouliez le dire :-)
Cdlt,
Répondre
Vaucluse 18256Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 2 décembre 2016 Dernière intervention - 2 déc. 2016 à 12:38
le égal après le A4 est une faute de frappe dont je suis un grand consommateurs :-)) ou plutôt :-((

supprimez le et ça devrait aller

en fait, je ne sais pas trop ce que fait votre formule, car nous n'avons pas les fichiers liés
tout ce, que je peux dire c'est que:
=ENT(LIGNE(A4)/4)+1 renvoi 2 sur les lignes 2,3,4,5.... 3 sur les lignes 6,7,8,9 etc....
en fait l'entier du N° de ligne en la cellule entre parenrthèses, divisé par quatre et auqel on ajoute 1

ce qui revient aussi au même sur ligne 2 à ma seconde proposition
ENT(LIGNE(A8)/4)

voyez ici
http://www.cjoint.com/c/FLclLw4WObD

par contre il y a peut être des parenthèses à ajuster, votre formule devrait s'écrire je pense:

=SI(ENT(LIGNE(A8)/4)<=NBVAL(NOMFEUILLES);INDEX(NOMFEUILLES;ENT(LIGNES(A8)/4);""))

ce qui renvoie aussi #VALEUR chez moi, car je n'ai pas le lien avec le fichier source pour controler à quoi correspond "NOMFEUILLE"
Ce #VALEUR disparait si je le remplace à titre d'exemple par J3:J20
et tout fonctionne
crdlmnt
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !