Signaler

2 fonctions Vrai dans une cellule [Résolu]

Posez votre question godinsonia 15Messages postés dimanche 22 août 2010Date d'inscription 5 décembre 2016 Dernière intervention - Dernière réponse le 29 nov. 2016 à 19:43
Bonjour,
j'aimerais mettre dans ma formule si D2= 1 vrai 39 et si D2 =2 vrai 61.50 si faux rien ("")
je ne sais pas si cela peut se faire ou non.

voici ma formule erronée: =SI(OU(D2=1;2);39;61,5;"";"")

merci de m'aider

Sonia
Afficher la suite 
Utile
+0
moins plus
Bonjour
=SI(D2=1;39;SI(D2=2;61,5;""))
crdlmnt
godinsonia 15Messages postés dimanche 22 août 2010Date d'inscription 5 décembre 2016 Dernière intervention - 29 nov. 2016 à 18:23
MERCI beaucoup ! et si on a plus de 2 conditions, genre 3....la formule serait quoi svp
Répondre
Vaucluse 18287Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 29 nov. 2016 à 18:26
=SI(Cell=condition1;résultat1,SI(Cell=condition 2;résultat2;SI(Cell=condition3;résultat3;SI(....;SI(....;"")))))
avec à la fin autant de parenhèses que de SI.
Mais si vous en avez beaucoup mieux vaut passer par un tableau de références et une formule de recherche
cham
crdlmnt
Répondre
godinsonia 15Messages postés dimanche 22 août 2010Date d'inscription 5 décembre 2016 Dernière intervention - 29 nov. 2016 à 19:11
merci beaucoup c'est super gentil de m'aider

malheureusement je ne me souviens plus comment faire avec une formule de recherche mais je vais essayer de trouver.

bonne journée
Sonia
Répondre
Vaucluse 18287Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 29 nov. 2016 à 19:43
tableau de recherche

exemple à adapter

de X1 à x10 la liste des valeurs (ou textes) de la cellule condition Cell
de Y1 à Y10 la liste des valeurs à obtenir en conséquence

dans la cellule résultat

=SIERREUR(RECHERCHEV(Cell;$X$1:$Y$10;2;0);"")

ou pour excel avant 2007

=SI(NB.SI($X$1:$X$10;Cell);RECHERCHEV(Cell;$X$1:$Y$10;2;0);"")

cell étant dans votre cas D2 sauf erreur


crdlmnt
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !