Signaler

HElppp plzzz Excel Fonction [Résolu]

Posez votre question Ams2020 4Messages postés mardi 29 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - Dernière réponse le 29 nov. 2016 à 15:35
Bonjour et merci d'avance

vous trouvez ma question dans la l'image ci-joint






Merci bqqqqqqqqq
Afficher la suite 
Utile
+0
moins plus
Bonjour
si votre tableau commence en A:

=NB.SI.ENS(F:F;"<0";G:G;"<100%")
_ pour excel à partir de 2007

Excel, avant 2007:
=SOMMEPROD((F1:F1000<0)*(G1:G1000<100%))
(N° de lignes obligatoires avec ce code)

Pour éviter d'afficher des jours négatifs dans la colonne temps restant si la tâche est finie, vous devriez placer cette formule:
=SI(G2=100%;"";AUJOURDHUI()-date début)

la formule pour compter les taches en retard serait plus simple:

=NB.SI(F:F;"<0")


crdlmnt

Ams2020 4Messages postés mardi 29 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 29 nov. 2016 à 10:54
MErci bqqq mais ca marche si il a que le metier achat
par contre moi jai d'autre metier commerce / conception et autre

moi je veux que le nombre des taches en retard par metier

Merci bqqqqqqqqqq Vaucluse
Répondre
Vaucluse 18330Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 11 décembre 2016 Dernière intervention - 29 nov. 2016 à 11:39
Votre tableau ne précisait pas qu'il y avait plusieurs métiers, ikl suffit de rajouter une co,ndition:

=NB.SI.ENS(C:C;E11;F:F;"<0";G:G;"<100%")

=SOMMEPROD(($C$1:$C$1000=E11)*($F$1:$F$1000<0)*($G$1:$G$1000<100%))

crdlmnt
Répondre
Ams2020 4Messages postés mardi 29 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 29 nov. 2016 à 15:35
MErci bqqq
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bonjour Ams2020,

Vaucluse (que je salue) t'a donné une très bonne solution et de
très bons conseils ; c'est en suivant ce qu'il a proposé que je te
joins ce fichier Excel 2007.

En F3   : =SI(G3<1;E3-F$7;"")
En F11 : =NB.SI.ENS(C3:C5;E11;F3:F5;"<0")

Donc j'ai bien suivi son conseil d'afficher le temps restant seulement
si Réalisé < 100 % ; mais par contre, je crois qu'il est préférable de
mettre les numéros de ligne même pour NB.SI.ENS() car la formule
elle-même est en colonne F puisqu'en F11.

J'ai supposé que dans ton vrai fichier il y a bien évidemment plus de
lignes, et au cas où tu as quand même mis ta formule en colonne F,
ma formule avec numéros de lignes « s'arrêtera » à la dernière ligne
de ton tableau (si tu as adapté correctement).

Si ton problème est réglé, n'oublie pas de remercier Vaucluse, puis
d'aller en haut de page pour cliquer sur « Marquer comme résolu ».

Cordialement.  :)
 
Ams2020 4Messages postés mardi 29 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 29 nov. 2016 à 15:35
MErci bqqqq
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !